Opened 5 years ago

Closed 5 years ago

#7129 closed defect (duplicate)

Gajim takes 50% CPU and doesn't respond

Reported by: grzegorz janoszka Owned by:
Priority: normal Milestone:
Component: None Version: 0.15
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All


Shortly after start, gajim starts to consume 50% CPU. It is not responding to mouse clicks, I don't see any incoming messages. Interaction with the application is not possible. I can only kill the process. After restart, gajim works again, sometimes few minutes, sometimes few hours, then it goes again into high CPU and unresponsiveness. Windows 7 SP1. All previous versions of gajim worked without any problems.

Change History (4)

comment:1 Changed 5 years ago by grzegorz janoszka

I think I found what triggers it - when you close the chat window there is about 5-10% chance that gajim will start using high cpu and be not responsive. Especially very fast closing of the chat window, like typing something and closing it in the very same second seems to kill gajim with a much higher chance. The machine has 2GB RAM, Intel core i3 CPU, no problems with any other apps.

comment:2 Changed 5 years ago by grzegorz janoszka

Sometimes instead of taking 50% CPU it just crashes:

Problem signature:

Problem Event Name: APPCRASH Application Name: gajim.exe Application Version: Application Timestamp: 4d853bef Fault Module Name: libgtk-win32-2.0-0.dll Fault Module Version: Fault Module Timestamp: 4f32dc49 Exception Code: c0000005 Exception Offset: 000085c5 OS Version: 6.1.7601. Locale ID: 1043 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789 Additional Information 3: 0a9e Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

comment:3 Changed 5 years ago by grzegorz janoszka

A bug opened two weeks ago, any update?

comment:4 Changed 5 years ago by asterix

  • OS changed from Windows to All
  • Resolution set to duplicate
  • Status changed from new to closed

if you have more time that we have to debug this problem, don't hesitate!

Are you able to reproduce if you disable the option "escape_key_closes"?

It seems it's duplicate of #6903

I can reproduce sometime, but I still have no idea why it happens :/

Note: See TracTickets for help on using tickets.