Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#7111 closed defect (fixed)

GPG. unable send encrypted message to user that hase gone offline

Reported by: billic Owned by: Yann Leboulanger <asterix@…>
Priority: normal Milestone: 0.16
Component: chat Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

cannot send gpg encrypted message to user that has gone offline after gpg encrypted chat session

expected behaviour: message sent

actual behaviour: message not sent, error message displayed: "error while sending <message> ( Neither the remote presence is signed, nor a key was assigned. )".

Steps to reproduce

  1. create and connect two jabber users
  2. start gpg encrypted chat between them.
  3. make one user offline.
  4. try to send encrypted message to that (offline) user from the other (online) user.

there is no problem after user comes back online.

There is a workarond: re-assign user's gpg key every time remote user goes offline (Manage contact -> assign opengpg key -> ok).

gajim -v gives me 1M of logs... I can attach it, if need.

Software versions

OS version: Debian GNU/Linux
GTK version: 2.24.8
PyGTK version: 2.24.0
Gajim 0.15-beta2-0b35dd2016dd (debian nightly 20120218-1 package)

Change History (8)

comment:1 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from new to closed

(In [4a0392615d81]) don't override assigned GPG key. Fixes #7111

comment:2 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [710c1ada0cdf]) don't override assigned GPG key. Fixes #7111

comment:3 Changed 3 years ago by meekstone

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm reopening this bug because I'm experiencing this behaviour in the default hg branch.

comment:4 follow-up: Changed 3 years ago by asterix

I don't have any problem with latest hg. Which version are you using?

comment:5 in reply to: ↑ 4 Changed 3 years ago by meekstone

Replying to asterix:

I don't have any problem with latest hg. Which version are you using?

Right now I'm using the hg version I pulled this morning. It identifies as "Gajim 0.15.4.0-0b2cacade877".

I can choose any offline contact to which I have assigned an OpenPGP key. Upon trying to send an encrypted message, Gajim will tell me "Neither the remote presence is signed, nor a key was assigned." But there is a key assigned when I check via "Manage contact" -> "Assign OpenPGP Key...".

comment:6 Changed 3 years ago by asterix

ok so it's not the same error as the this ticket. re-assigning a key works in your case. Fixing your issue.

comment:7 Changed 3 years ago by asterix

  • Milestone changed from 0.15 to 0.16
  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in [e23d3603521f]

comment:8 Changed 3 years ago by Yann Leboulanger <asterix@…>

  • Owner set to Yann Leboulanger <asterix@…>

In e23d3603521f42e97235bf9dab3cb1d43df19628:

read assigned GPG key when creating the contacts. fixes: #7111

Note: See TracTickets for help on using tickets.