Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#7044 closed defect (fixed)

Whiteboard plugin failing silently

Reported by: buymebeer Owned by:
Priority: normal Milestone: 0.15
Component: plugins Version: hg
Severity: normal Keywords: plugins usability whiteboard
Cc: ioerror Blocked By:
Blocking: OS: All

Description

Bug description

Traceback (most recent call last):

File "../plugins/whiteboard/plugin.py", line 328, in on_whiteboard_button_toggled

self.start_whiteboard()

File "../plugins/whiteboard/plugin.py", line 336, in start_whiteboard

conn._sessions[jingle.sid] = jingle

AttributeError?: 'Connection' object has no attribute '_sessions' Traceback (most recent call last):

File "../plugins/whiteboard/plugin.py", line 330, in on_whiteboard_button_toggled

self.stop_whiteboard()

File "../plugins/whiteboard/plugin.py", line 345, in stop_whiteboard

session = conn.get_jingle_session(self.jid, media='xhtml')

AttributeError?: 'Connection' object has no attribute 'get_jingle_session'

Steps to reproduce

  • Enable the plugin
  • Open a chat and click "Whiteboard". This happened for me when doing this - but probably not for everybody using the plugin :-)

Change History (3)

comment:1 Changed 5 years ago by asterix

The reason is that you don't have farsight installed. I look at that.

comment:2 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In [4040f2e35429]) ability to use jingle negociation even if we don't have farsight. Fixes #7044

comment:3 Changed 4 years ago by Yann Leboulanger <asterix@…>

(In [a5feea98a5ef]) ability to use jingle negociation even if we don't have farsight. Fixes #7044

Note: See TracTickets for help on using tickets.