Opened 5 years ago

Closed 5 years ago

#7005 closed defect (fixed)

user message appears as presence message(green color) && not logged in History

Reported by: harrykar Owned by:
Priority: high Milestone: 0.15
Component: chat Version: 0.14.4
Severity: critical Keywords: history, message_window
Cc: Blocked By:
Blocking: OS: Unix

Description

Bug description

user message appears as presence message(green color) && not logged in History(see http://picpaste.com/Screenshot-4-oKe0NC9i.png). I must restart gajim to have again normal chat functionality

Steps to reproduce

i don't know exactly how to reproduce. All i know is gajim was in execution for some day. I 'm in standby when that instance re-present again

Software versions

OS version: [Ubuntu 10.04] Gajim version: [0.14.4] GTK version: [2.20.1] PyGTK version: [2.17.0]

Attachments (2)

screenshot_001.png (47.6 KB) - added by harrykar 5 years ago.
see the mgs at 11.12.29AM
stanzas.txt.bz2 (2.7 KB) - added by harrykar 5 years ago.
xml stanzas about green messages

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by harrykar

see the mgs at 11.12.29AM

comment:1 Changed 5 years ago by asterix

  • Status changed from new to needinfo

please get XML stanza that you get when that happens

Changed 5 years ago by harrykar

xml stanzas about green messages

comment:2 Changed 5 years ago by harrykar

That's weird; neither the plain .txt was accepted(considered also as spam from track:

Submission rejected as potential spam (Akismet says content is spam, BlogSpam says content is spam (Cached from linksleeve.org), TypePad says content is spam, Defensio says content is not allowed (spam, 0.99, none), Maximum number of external links per post exceeded, Content contained these blacklisted patterns: '(?is)(?:http.*http.*http|www.*www.*www)')

). So i workaround it as .bz2

comment:3 Changed 5 years ago by asterix

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from needinfo to closed

in fact you receive error messages because your server cannot join conference.gajim.org it seems. so it's supposed to be presented to you as an error message: written in green (that's the case) with error message (that doesn't seem to be the case ...)

I can reproduce in 0.14 branch, but it's fixed in 0.15 branch. It's now clearly printed "error while sending MSG ( REASON )"

Note: See TracTickets for help on using tickets.