Opened 5 years ago

Last modified 4 years ago

#6991 new defect

Problem with notification

Reported by: x11term Owned by:
Priority: normal Milestone:
Component: notifications Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All


Bug description

When a message arrives, it displays a notification. After clicking the mouse in it comes up window with the message. All is fine, but the message box appears only once.

By clicking on any subsequent notice, nothing happens.

After restarting, gajim, all repeats, the first click works, the other does not.

Steps to reproduce

Click on the notification.

Software versions

Gajim version: 0.15-beta2-ce086d0f1a17
OS version: gentoo
GTK version: 2.24.6
PyGTK version: 2.24.0

Change History (9)

comment:1 Changed 5 years ago by asterix

I cannot reproduce, it works for me. Any idea on a way to reproduce?

comment:2 Changed 5 years ago by x11term

If you connect a single account, then everything works fine. If after some time to connect other accounts, it also works, but sometimes it disappears. And if you connect all the accounts at the same time, it only works the first time.

I connected three accounts,, (corporate) and

comment:3 Changed 5 years ago by asterix

I have 2 accouns connected all the time. I even tried with 2 instances of Gajim, still no problem. Do you have pynotify installed or are notifications send through D-Bus? Any error in console?

comment:4 Changed 5 years ago by x11term

installed dev-python/notify-python-0.1.1-r2. Do not know what is the role dbus in the transfer notice. No errors. gajim --loglevel=3 not see an error message.

comment:5 Changed 5 years ago by cYmen

which window manager are you using?

comment:6 Changed 5 years ago by x11term

gnome with metacity

comment:7 Changed 5 years ago by asterix

I experiment the same issue, and it's several days I try to debug that. The problem isn't in Gajim IMHO:

here is whay I have gathered. When a progrm (Gajim or something else) send a notification, it gets an id that is increased by one (first one is 1, then 2, etc...

and Gajim registers a callback for the "ActionInvoked?" signal, which is raised in dbus-monitor when we click on the notification.

The problem is that, sometimes (I don't know when / why) the id number restarts from 1 and callback is no more called.

The restart from 1 can happen after id reaches a small number (18) or a big number (more than 100) without any visible reason.

I follow that by running dbus-monitor "interface='org.freedesktop.Notifications'"

no idea what happens, and the only fix I Can see is to re-register the callback from time to time: abslutly ugly fix!

comment:8 Changed 4 years ago by Darlan

Related ticket #6891

I suspect it is a problem with the notification itself under certain window managers (I suspect Fluxbox is one of them).

Last edited 4 years ago by Darlan (previous) (diff)

comment:9 Changed 4 years ago by asterix

not only with fluxbox. The problem is most probably with notification-daemon which restarts counting from 0.

I have the same issue and I don't use fluxbox

Note: See TracTickets for help on using tickets.