Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6974 closed defect (fixed)

Crash when receiving some Unicode characters

Reported by: harrykar Owned by:
Priority: high Milestone: 0.15
Component: chat Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: Unix

Description

Bug description

for some reason maybe after a black out my system goes off. When i restart it i notice that when gajim loads gajim room gajim app crashes

Steps to reproduce

right now crash reproduce every time i start gajim without close gajim room(autoload at every gajim start)

Software versions

OS version: Ubuntu Lucid lynx 10.04 LTS Gajim 0.14.4 GTK version:2.20.10.14.4 PyGTK version:2.17.0

Attachments (2)

gajim.log3.bz2 (45.9 KB) - added by harrykar 5 years ago.
loglevel 3
gajim.vc.diff (671 bytes) - added by Dicson 5 years ago.

Download all attachments as: .zip

Change History (17)

Changed 5 years ago by harrykar

loglevel 3

comment:1 in reply to: ↑ description Changed 5 years ago by harrykar

Replying to harrykar:

Bug description

for some reason maybe after a black out my system goes off. When i restart it i notice that when gajim loads gajim room gajim app crashes

Steps to reproduce

right now crash reproduce every time i start gajim without close gajim room(autoload at every gajim start)

Software versions

OS version: Ubuntu Lucid lynx 10.04 LTS Gajim 0.14.4 GTK version:2.20.10.14.4 PyGTK version:2.17.0

Tnx to @Zash a leave and rejoin solve the problem

Version 0, edited 5 years ago by harrykar (next)

comment:2 Changed 5 years ago by Zash

Looks like a U+FDEF is sent, which causes a crash.

comment:3 Changed 5 years ago by Zash

  • Summary changed from Gajim crash every time i start it without close gajim room(set to autoload at every gajim start) to Crash when receiving some Unicode characters

comment:4 Changed 5 years ago by Dicson

I think we have nothing here to fix. The problem in a specific distributive

comment:5 Changed 5 years ago by Dicson

dup #5702

comment:6 Changed 5 years ago by asterix

the problem seems to be in dbus / python-dbus. see this bugreport

Changed 5 years ago by Dicson

comment:7 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from new to closed

(In [5e51aecfbaf4]) transform non-character unicode to ? char (\ufffd) as soon as we receive them. Fixes #6974

comment:8 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [fb912e9b4c70]) also replace non-character unicode AFTER decryption. Fixes #6974

comment:9 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [d66a2440ffcb]) transform non-character unicode to ? char (\ufffd) as soon as we receive them. Fixes #6974

comment:10 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [edee77edeb8f]) also replace non-character unicode AFTER decryption. Fixes #6974

comment:11 Changed 5 years ago by dos

  • Resolution fixed deleted
  • Status changed from closed to reopened

My gajim with this patch still crash on startup from this stanza:

16:46:28 (D) gajim.common.ged STANZA_ARRIVED
Args: (u'comrade_dos@jabber.ru', u"<message from='linux@conference.jabber.ru/artemz' to='comrade_dos@jabber.ru/work' type='groupchat'><body>\ufdef</body><delay xmlns='urn:xmpp:delay' from='linux@conference.jabber.ru' stamp='2011-10-28T02:23:55Z'></delay><x xmlns='jabber:x:delay' stamp='20111028T02:23:55'/></message>")
16:46:28 (I) gajim.c.x.simplexml STARTTAG.. DEPTH -> 2 , tag -> message, attrs -> {u'to': u'comrade_dos@jabber.ru/work', u'from': u'linux@conference.jabber.ru/artemz', u'type': u'groupchat'}
16:46:28 (I) gajim.c.x.simplexml STARTTAG.. DEPTH -> 3 , tag -> body, attrs -> {}
16:46:28 (I) gajim.c.x.simplexml DEPTH -> 3 , tag -> body
16:46:28 (I) gajim.c.x.simplexml STARTTAG.. DEPTH -> 3 , tag -> delay, attrs -> {u'stamp': u'2011-10-28T02:23:55Z', u'xmlns': u'urn:xmpp:delay', u'from': u'linux@conference.jabber.ru'}
16:46:28 (I) gajim.c.x.simplexml DEPTH -> 3 , tag -> delay
16:46:28 (I) gajim.c.x.simplexml STARTTAG.. DEPTH -> 3 , tag -> x, attrs -> {u'stamp': u'20111028T02:23:55', u'xmlns': u'jabber:x:delay'}
16:46:28 (I) gajim.c.x.simplexml DEPTH -> 3 , tag -> x
16:46:28 (I) gajim.c.x.simplexml DEPTH -> 2 , tag -> message
16:46:28 (D) gajim.c.x.dispatcher_nb Got jabber:client/message stanza
16:46:28 (D) gajim.c.connection_handlers MessageCB
16:46:28 (D) gajim.common.ged GC_MSG
Args: (u'comrade_dos@jabber.ru', (u'linux@conference.jabber.ru/artemz', u'\ufdef', time.struct_time(tm_year=2011, tm_mon=10, tm_mday=28, tm_hour=9, tm_min=23, tm_sec=55, tm_wday=4, tm_yday=301, tm_isdst=0), True, None, [], None, None))
/usr/lib64/python2.7/site-packages/gajim/conversation_textview.py:1032: GtkWarning: gtk_text_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
  insert_tags_func(end_iter, otext[index:], *other_tags)

comment:12 Changed 5 years ago by asterix

  • Resolution set to fixed
  • Status changed from reopened to closed

I don't know what "this patch" mean, but we cannot debug your version of Gajim that you modified. Please use 0.15 beta2 which have correct patches about yhis issue.

comment:13 Changed 5 years ago by dos

"This patch" - patch attached in this ticket.

comment:14 Changed 5 years ago by asterix

it's not the one we implemented in Gajim, so it's normal you still have problems. Use 0.15 beta2 or look at commits in 0.15 branch about that. There a several.

Note: See TracTickets for help on using tickets.