Opened 5 years ago

Closed 5 years ago

#6943 closed defect (fixed)

Problems with the Banned dialog

Reported by: Darlan Owned by:
Priority: high Milestone: 0.15
Component: dialogs Version: 0.14.4
Severity: trivial Keywords: top, bottom, window, dialog
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

  1. The dialog doesn't stay on top, unlike this dialog. (See #6892 #6942). The dialog is blocking mouse click interactions with the other windows and yet it isn't on top of them.
  1. It is Unnamed.
  1. Since the moment when I was banned I had this or another banned dialog popping up constantly, I had 4 - 5 dialogs which restored themselves each time I have closed (pressed OK) they appeared again. The number of these dialogs stayed the same. (need to reproduce)

Steps to reproduce

None.

Software versions

OS version: Salix OS 13.37 (Slackware 13.37 based)
WM version: Fluxbox 1.3.1
GTK version: 2.24.4
PyGTK version: 2.22.0

Attachments (6)

ban1.png (125.2 KB) - added by Darlan 5 years ago.
ban2.png (152.8 KB) - added by Darlan 5 years ago.
ban3.png (142.0 KB) - added by Darlan 5 years ago.
48.png (10.2 KB) - added by Dicson 5 years ago.
gajim.vc.diff (3.2 KB) - added by Dicson 5 years ago.
gajim.vc.2.diff (2.9 KB) - added by Dicson 5 years ago.

Download all attachments as: .zip

Change History (24)

Changed 5 years ago by Darlan

Changed 5 years ago by Darlan

Changed 5 years ago by Darlan

comment:1 in reply to: ↑ description Changed 5 years ago by dotdoom

  • OS changed from Unix to All

confirmed on Linux and Win7. It'd be much better to have an account name in dialog header.

Dialogs are reopening with an interval of exactly 5 minutes. Working on a reproducing sequence.

Changed 5 years ago by Dicson

comment:2 Changed 5 years ago by Dicson

attached patch fix 1(dialog.set_modal(False)) and 2(set account name as window title). Use bold for room jid

Last edited 5 years ago by Dicson (previous) (diff)

Changed 5 years ago by Dicson

comment:3 Changed 5 years ago by asterix

I modified a bit your patch to set transient window, and don't set a title. Gnome HIG says to not set title for alert windows.

comment:4 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from new to closed

(In [f7a45be37bf5]) correctly set transient window for muc error dialogs. Fixes #6943

comment:5 Changed 5 years ago by dotdoom

  • Status changed from closed to needinfo

what about p. 3 with reopening windows?

comment:6 Changed 5 years ago by asterix

it will popup ech time you try to connect, but once I am banned, Gajim doesn't try to connect (except if it's minimized in your roster, is it the case?). Else explain how you can reproduce that, I cannot

comment:7 Changed 5 years ago by dotdoom

I'm already trying to find out the way to reproduce it.

Meanwhile I found another issue

  • try to join the groupchat you are banned in
  • close an alert
  • tick the 'Minimize on close' checkbox in the new tab of empty chat
  • close it (i.e. minimize to roster)
  • try to join it again (Actions>Join Group Chat...) and you will get an alert 'This is not a groupchat'. It is a bit confusing. Althought it's not very common sequence, this may be a source of some other problem.

Thanks

Artem

comment:8 Changed 5 years ago by Dicson

alert 'This is not a groupchat' - this problem fixed in the hg version

comment:9 Changed 5 years ago by dotdoom

  • Status changed from needinfo to new

Thanks Dicson.

I was able to reproduce that bug with ban dialogs resuming:

  • try to join the room you are banned in
  • observe the Banned dialog. Close it
  • don't close the chattab. Let you autostatus fire 'away' presence
  • observe <presence> stanza to the room in the XML console and the Banned dialog reappearing as a result of server response

this also explains why I got it with 5min interval: I have autoaway set for five minutes.

affects 0.14.4

Thanks

-Artem

comment:10 Changed 5 years ago by Dicson

Thanks dotdoom

I can repro this bug. If we don't close the chattab and change status - we have Banned dialog again

Last edited 5 years ago by Dicson (previous) (diff)

comment:11 Changed 5 years ago by Dicson

xml log then I change status http://pastebin.com/vTtQcE5E

comment:12 Changed 5 years ago by Dicson

quick fix in the attached patch

Changed 5 years ago by Dicson

comment:13 Changed 5 years ago by asterix

what about commenting line 2092-2093 in roster_window.py? This will just not connect to opened groupchats that are disconnected. Are there cases where it's usefull to connect to opened-disconnected groupchats?

comment:14 Changed 5 years ago by Dicson

maybe yes.but which point to close tab?

comment:15 Changed 5 years ago by asterix

because I don't want to loose said things that I haven't read before I'm banned for example.

comment:16 Changed 5 years ago by Dicson

patch don't close tab after ban. after receiving error stanza only

Last edited 5 years ago by Dicson (previous) (diff)

comment:20 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [1db2eb2ba130]) do not connect to opened disconnected groupchats. Fixes #6943

comment:21 Changed 5 years ago by dotdoom

  • Status changed from new to closed

thanks

Note: See TracTickets for help on using tickets.