Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6925 closed defect (fixed)

Several issues

Reported by: dotdoom Owned by:
Priority: normal Milestone: 0.14.4
Component: None Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Affected Gajim Version: 0.14.3

Hi,

this is not a bug report, it's rather an improvement suggestion. I've just got enough time to tell you guys about how much do I love Gajim and what do I hate about it.

For years Gajim was the only Jabber client I could be using without any significant problems; perhaps it's the best for me, because with this one I can travel from one machine to another, w/o even caring about if I'm using Linux or Windows on it; chatlogs are being kept in a sqlite database which allowed me to write a small script to transfer and synchronize logs between my home and work PCs, as well as the netbook with Windows 7 which I'm currently using to write this message.

So there's much about it; I wish I could contribute to the code, but I'm so sorry to know that I cannot do it in an observable future. At least I should learn Python well before making such things.

Well, time to talk about some issues I faced when using it. This really is not a breaker, but at least it messes something about Gajim, which proved to be be stable enough for me.

There's no sense in long prequels, so let's start:

  1. Well, the first one and most disturbing is connection stage. Really it's fast enough under normal circumstances but when we face some troubles with server or any other network issues Gajim hangs badly, disallowing me to type a message or any other activity. I know that synchronous network I/O is easier to use sometimes, but that's a hell, really.
  1. The second (not by priority) is a trouble with history manager. I'm not sure if everyone faced it or just me, but I cannot really clean my History from it. The button just... does nothing. So I need to use sqlite3 console or any GUI manager to remove extra entries. Creepy enough.
  1. Search. Yeah, that simple search through the roster. I can say that it actually works, but not that convenient. Say I usually collapse all groups in roster, the try to find a contact and get nothing, because a group with it is collapsed! Well maybe users with up to 30 contacts can keep their group expanded, but for me expanding a 700-user group is painful. The thing that search does not look into collapsed groups really drives me crazy. Can you please at least provide an option in Config manager (which btw is the best thing ever, omitting uncommented options) to search in all my roster? Would be great.
  1. One more regarding roster. I'm using Skype from time to time, and there's a very useful feature like 'Recent conversations', providing you with recent contacts u were talking to. Is there any chance of implementing such a thing in Gajim? 'Show only active contacts' seems good enough, but it hides offline contacts, which I would like to have just in case they'll turn online.
  1. Two Windows-specific issues (may be related to GTK so you will mark it WONTFIX but I'd better try):
    1. clipboard. A really strange hell is going on with my clipboard. Seems that when I copy from any Windows native application, the clipboard is shared with Gajim (ie I can paste in it), but when I copy from Gajim, it seem to open it's private clipboard for it, leaving me no chance to paste the text other than back in Gajim. This is kinda weird, isn't it?
    2. window position (when restored). This bug happens very often, although not that easy to reproduce. Say, I open Gajim wide fullscreen, then use Close button to minimize to tray. When restoring, it hides mostly beyond my desktop, forcing me to "ALT+SPACE" and open window menu, choose Restore, then maximize again. This doesn't happen when minimizing to taskbar though. Any ideas?
  1. Time for bugs! Well, there's one affiliated with Room management. When I open Room Configuration in one of my rooms, I've got a strange window offering me to send bugreport. A copy is here:

http://my.jetscreenshot.com/7042/20110716-fiap-83kb

I managed to get an XML log for it, and seen there's an entry in memberlist like "user ", which is likely not a valid JID. If that's not a case in your opinion, please feel free to contact me and request a full XML log (just don't want to publish it here, since the info is somekind private u know..)

  1. Oh, recent jabber features... CAPTCHA. Joining a password-protected room was buggy thing in Gajim before, now it's added up by captcha. Somehow I can get a report like this: http://my.jetscreenshot.com/7042/20110716-yrt4-82kb

here are the steps for it:

  1. Create a CAPTCHA-protected room
  2. Try to join with an unaffiliated account (so to be requested a CAPTCHA code)
  3. Do not type anything, just press OK
  4. U'r promted for password. Just press OK.
  5. CAPTCHA again. Just press OK
  6. Bump! A traceback appears. Sometimes even faster.

That's not the only case. Try to cancel password-protected room request, too. Or you can leave it waiting for you and then OK it. This can bring problems also.

So.. enough for today. Probably I forgot something, so I will post it later if you care.

I hope something of my messing will help you to make Gajim an Ultimate Jabber IM. If you aren't really interested in such suggestions, well it's always up to you. I just try to send some feedback to you, because from my own experience customers do omit such a thing pretty often and that's a pity to develop software w/o having users in mind.

Thank you much for reading this. My contact e-mail: dot.doom (at) gmail.com. In case you need more info on it

PS: would also be great to have a "Show VCard" option in "Add Contact" dialog, thus avoiding extra mouse clicks..

Software versions

OS version: Microsoft (R) Windows (R) 7 Version 6.1.7601 (SP1)
GTK version: 2.24.0
PyGTK version: 2.22.0

Thanks

-Artem

Change History (13)

comment:1 in reply to: ↑ description ; follow-up: Changed 5 years ago by Dicson

Replying to dotdoom:

  1. The second (not by priority) is a trouble with history manager. I'm not sure if everyone faced it or just me, but I cannot really clean my History from it. The button just... does nothing. So I need to use sqlite3 console or any GUI manager to remove extra entries. Creepy enough.


Delete from the menu by right-clicking does not work as well?

comment:2 in reply to: ↑ 1 Changed 5 years ago by dotdoom

Replying to Dicson:

Replying to dotdoom:

  1. The second (not by priority) is a trouble with history manager. I'm not sure if everyone faced it or just me, but I cannot really clean my History from it. The button just... does nothing. So I need to use sqlite3 console or any GUI manager to remove extra entries. Creepy enough.


Delete from the menu by right-clicking does not work as well?

oh just noticed it's 0.14.1 here (jah), updating to 0.14.3 actually solved it. Applies to only this issue though, since others definitely persist on 0.14.3. Thank you for pointing me this out anyway!

this one being fixed is yet another prove that Gajim is actively supported. Cheers!

-Artem

comment:3 in reply to: ↑ description ; follow-up: Changed 5 years ago by asterix

Replying to dotdoom:

Hi,

Hi

  1. Well, the first one and most disturbing is connection stage. Really it's fast enough under normal circumstances but when we face some troubles with server or any other network issues Gajim hangs badly, disallowing me to type a message or any other activity. I know that synchronous network I/O is easier to use sometimes, but that's a hell, really.

the only synchronous thing is DNS request, but we optionaly use python-libasyncns to do them. All other network and GUI things are asynchronous (At least we try to). Do you have that installed?

  1. Search. Yeah, that simple search through the roster. I can say that it actually works, but not that convenient. Say I usually collapse all groups in roster, the try to find a contact and get nothing, because a group with it is collapsed! Well maybe users with up to 30 contacts can keep their group expanded, but for me expanding a 700-user group is painful. The thing that search does not look into collapsed groups really drives me crazy. Can you please at least provide an option in Config manager (which btw is the best thing ever, omitting uncommented options) to search in all my roster? Would be great.

trunk version has that implemented. see #5221

  1. One more regarding roster. I'm using Skype from time to time, and there's a very useful feature like 'Recent conversations', providing you with recent contacts u were talking to. Is there any chance of implementing such a thing in Gajim? 'Show only active contacts' seems good enough, but it hides offline contacts, which I would like to have just in case they'll turn online.

hmmm it's a very specific thing ... I don't have a very high interest in that, but why not adding a hook in the filter function so that a plugin can be written.

  1. Two Windows-specific issues (may be related to GTK so you will mark it WONTFIX but I'd better try):
    1. clipboard. A really strange hell is going on with my clipboard. Seems that when I copy from any Windows native application, the clipboard is shared with Gajim (ie I can paste in it), but when I copy from Gajim, it seem to open it's private clipboard for it, leaving me no chance to paste the text other than back in Gajim. This is kinda weird, isn't it?

Reported here: #6923

  1. window position (when restored). This bug happens very often, although not that easy to reproduce. Say, I open Gajim wide fullscreen, then use Close button to minimize to tray. When restoring, it hides mostly beyond my desktop, forcing me to "ALT+SPACE" and open window menu, choose Restore, then maximize again. This doesn't happen when minimizing to taskbar though. Any ideas?

Reported here: #5782 (I think it's your issue)

  1. Time for bugs! Well, there's one affiliated with Room management. When I open Room Configuration in one of my rooms, I've got a strange window offering me to send bugreport. A copy is here:

http://my.jetscreenshot.com/7042/20110716-fiap-83kb

I managed to get an XML log for it, and seen there's an entry in memberlist like "user ", which is likely not a valid JID. If that's not a case in your opinion, please feel free to contact me and request a full XML log (just don't want to publish it here, since the info is somekind private u know..)

Indeed this is an invalid JID. But there should not be such a traceback, it should just be ignored. I tested and I'm not able to reproduce. Could you show me just the small part of XML with this invalid JID?

  1. Oh, recent jabber features... CAPTCHA. Joining a password-protected room was buggy thing in Gajim before, now it's added up by captcha. Somehow I can get a report like this: http://my.jetscreenshot.com/7042/20110716-yrt4-82kb

here are the steps for it:

  1. Create a CAPTCHA-protected room
  2. Try to join with an unaffiliated account (so to be requested a CAPTCHA code)
  3. Do not type anything, just press OK
  4. U'r promted for password. Just press OK.
  5. CAPTCHA again. Just press OK
  6. Bump! A traceback appears. Sometimes even faster.

That's not the only case. Try to cancel password-protected room request, too. Or you can leave it waiting for you and then OK it. This can bring problems also.

Thanks for the report, fix arrives in some seconds

PS: would also be great to have a "Show VCard" option in "Add Contact" dialog, thus avoiding extra mouse clicks..

We have that when we receive a request, but not when adding (you're supposed to know who you add, no?)

comment:4 Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [02c5e2e21574]) cleanup gc_control.error_dialog attribute when we close the error dialog. See #6925

comment:5 in reply to: ↑ 3 ; follow-ups: Changed 5 years ago by dotdoom

  1. Network: I don't actually know how does Gajim installer behave on Windows, but unfortunately it's the only place I face network problems at. I will check if it's DNS-related issue right when having an opportunity to do this.
  1. Search:

    trunk version has that implemented. see #5221

that's cool, thanks

  1. 'Recent conversations': thank you. I'm interested in plugin development for Gajim, I think it's a recent feature because did not know about it before.
  1. Thanks for pointing to it, I think I'd like to watch it
  1. Room Config: I've sent you an e-mail with full XML log causing an error. Can you please review?

7.

Thanks for the report, fix arrives in some seconds

Sounds great, thank you!

Show VCard: yeah, I'm really supposed to, but I also would like to know if I didn't misspelled the JID, not to add wrong person occasionally. Anyway it's just cosmetic, so please don't mind if you do not feel the same way.

Thank you,

-Artem

comment:6 in reply to: ↑ 5 ; follow-up: Changed 5 years ago by asterix

Replying to dotdoom:

  1. 'Recent conversations': thank you. I'm interested in plugin development for Gajim, I think it's a recent feature because did not know about it before.

Yep there is currently no release with that, only development version in mercurial.

  1. Room Config: I've sent you an e-mail with full XML log causing an error. Can you please review?

Yep I've looked at it, but there are many many JIDs, so hard to know which one is causing the issue. I tested several with wrong JID ("xxx ", "*", ...) But I'm never able to reproduce. Could you enable verbose in advanced configuration window? that should create a log file (I'm not sure where it is, something like document and settings\USER\application data\roaming\Gajim or something like that ...

comment:7 in reply to: ↑ 6 Changed 5 years ago by dotdoom

Replying to asterix: Sure I can. I will send it to you in a minute.

comment:8 in reply to: ↑ 5 Changed 5 years ago by asterix

Replying to dotdoom:

  1. Network: I don't actually know how does Gajim installer behave on Windows, but unfortunately it's the only place I face network problems at. I will check if it's DNS-related issue right when having an opportunity to do this.

Indeed this package doesn't exist for widnows. I don't know any other package to do async DNS requests.

comment:9 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from new to closed

(In [76f21c4e5c58]) fix nameprep for wrong jids. Fixes #6925

comment:10 follow-up: Changed 5 years ago by Yann Leboulanger <asterix@…>

(In [3cb11e1c2d6a]) cleanup gc_control.error_dialog attribute when we close the error dialog. See #6925

comment:11 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone changed from 0.15 to 0.14.3

(In [7bb6c6b8c2c1]) fix nameprep for wrong jids. Fixes #6925

comment:12 Changed 5 years ago by asterix

  • Milestone changed from 0.14.3 to 0.14.4

comment:13 in reply to: ↑ 10 Changed 5 years ago by dotdoom

(In [3cb11e1c2d6a]) cleanup gc_control.error_dialog attribute when we close the error dialog. See #6925

(In [7bb6c6b8c2c1]) fix nameprep for wrong jids. Fixes #6925

it works! Thank you!

Note: See TracTickets for help on using tickets.