Opened 5 years ago

Closed 5 years ago

#6923 closed defect (fixed)

Copy from chat window stopped working in 0.14.3

Reported by: grzegorz janoszka Owned by:
Priority: normal Milestone:
Component: chat Version: 0.14.1
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: Windows


Bug description

Copying (C) stopped working in 0.14.3. It worked well in 0.14.2. What is interesting - the marked text is blue as long as the chat window is focused (selected) and I can copy it and paste to the very same chat window. It turns red whenever I switch to other window and then it is impossible to paste it, it just disappears from the clipboard. I marked version 0.14.2 below, as the dropdown didn't have 0.14.3, but 0.14.2 didn't have the bug, it has been introduced after I upgraded to 0.14.3.

Steps to reproduce

Open a chat window to someone, try to copy something to clipboard and paste it to any other window.

Software versions

OS version: Windows 7 SP1
GTK version: Gajim 0.14.3 windows install
PyGTK version: Gajim 0.14.3 windows install

Change History (4)

comment:1 Changed 5 years ago by asterix

  • Version changed from 0.14.2 to 0.14.1

In fact it seems the same problem appear in Gajim 0.14.1. We can past in another window of Gajim, but not in a window outside of Gajim (like notepad).

comment:2 Changed 5 years ago by dotdoom

Gajim 0.14.4 (from Windows Installer)

Windows 7 SP1

GTK+ Version: 2.22.1

PyGTK Version: 2.22.0

not reproducible. Looks like even bugfix versions are more lucky (joke; thank you of course)

comment:3 Changed 5 years ago by dotdoom

just curious, is it a GTK+ downgrade which solved the problem? AFAIR 0.14.3 had 2.24.0 pre-packed.

looks like they've recently fixed some issue with it:

comment:4 Changed 5 years ago by grzegorz janoszka

  • Resolution set to fixed
  • Status changed from new to closed

I can confirm it has been fixed in 0.14.4. The bug existed only in 0.14.3. Thanks.

Note: See TracTickets for help on using tickets.