Opened 5 years ago

Closed 5 years ago

#6867 closed defect (worksforme)

Sporadic problem with Google Talk Accounts

Reported by: lathan Owned by:
Priority: normal Milestone:
Component: None Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

At Random times, my jabber account setup for talk.google.com won't connect, resulting in two popup errors: 1) Authentication failed with "gmail.com"

-Please check your login and password for correctness.

2) A programming error has been detected

-It probably is not fatal, but should be reported to the developers nonetheless.

Details:

Traceback (most recent call last):
  File "/usr/share/gajim/src/common/xmpp/idlequeue.py", line 497, in _process_events
    return IdleQueue._process_events(self, fd, flags)
  File "/usr/share/gajim/src/common/xmpp/idlequeue.py", line 367, in _process_events
    obj.pollin()
  File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 405, in pollin
    self._do_receive()
  File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 585, in _do_receive
    self._on_receive(received)
  File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 597, in _on_receive
    self.on_receive(data)
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 293, in <lambda>
    self.onreceive(lambda _data:self._xmpp_connect_machine(mode, _data))
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 327, in _xmpp_connect_machine
    self._xmpp_connect_machine(mode='STREAM_STARTED')
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 346, in _xmpp_connect_machine
    self._on_stream_start()
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 362, in _on_stream_start
    self._on_connect()
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 415, in _on_connect
    self.on_connect(self, self.connected)
  File "/usr/share/gajim/src/common/connection.py", line 680, in _connect_success
    return self.connection_accepted(con, con_type)
  File "/usr/share/gajim/src/common/connection.py", line 739, in connection_accepted
    on_auth=self.__on_auth)
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 445, in auth
    self._on_doc_attrs()
  File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 470, in _on_doc_attrs
    if not self._sasl or self.SASL.startsasl == 'not-supported':
AttributeError: NonBlockingClient instance has no attribute 'SASL'

Steps to reproduce

Jabber account to Host: talk.google.com Port: 5222 Hard to reproduce, but when connecting, only about once per month. It may be an interaction with some failure on talk.google.com

Software versions

OS version: Ubuntu: 2.6.35-28-generic #50-Ubuntu SMP x86_64 GNU/Linu

GTK version: 2.20.1-1ubuntu1 (maverik) (version from Synaptic Package Manager)

PyGTK version: 2.21.0-0ubuntu1 (maverik) (version from Synaptic Package Manager)

Attachments (6)

gajim-gtalk-error1.png (13.9 KB) - added by lathan 5 years ago.
gajim-gtalk-error2.png (140.9 KB) - added by lathan 5 years ago.
gajim.log.0 (375.2 KB) - added by lathan 5 years ago.
Log of problem (file 1/4)
gajim.log.1 (331.2 KB) - added by lathan 5 years ago.
Log of problem (file 2/4)
gajim.log.2 (476.8 KB) - added by lathan 5 years ago.
Log of problem (file 3/4)
gajim.log.3 (453.1 KB) - added by lathan 5 years ago.
Log of problem (file 4/4)

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by lathan

Changed 5 years ago by lathan

comment:1 Changed 5 years ago by asterix

  • Status changed from new to needinfo

full XML log would be usefull. Could you run gajim -v > logs.txt 2>&1 and attach result here?

comment:2 Changed 5 years ago by lathan

I will have to wait for the symptoms to appear again.

It seems to be a problem that comes up for 12-24 hours and then goes away for days to weeks....

I'll get the -v output the next time.

comment:3 Changed 5 years ago by asterix

  • Resolution set to worksforme
  • Status changed from needinfo to closed

please reoprn with requested information if you can reproduce

Changed 5 years ago by lathan

Log of problem (file 1/4)

Changed 5 years ago by lathan

Log of problem (file 2/4)

Changed 5 years ago by lathan

Log of problem (file 3/4)

Changed 5 years ago by lathan

Log of problem (file 4/4)

comment:4 Changed 5 years ago by lathan

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Adding log attachments, had to split log into 4 pieces to meet attachment size limit.

Note, this appears to only happen due to Google Talk server's behavior.

comment:5 Changed 5 years ago by asterix

Thanks for the logs. They are hard to read because you are trying to connect to 3 accounts, so logs of those 3 accounts are mixed. Could you tell me which Gajim version you use? Did you force using SSL?

comment:6 follow-up: Changed 5 years ago by lathan

I believe it is using SSL.

The next time it happens, I will disable the other 2 accounts, and show logs of just that one.

Gajim 0.13.4 GTK+ Version: 2.22.0 PyGTK Version: 2.21.0

comment:7 in reply to: ↑ 6 Changed 5 years ago by asterix

  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to lathan:

I believe it is using SSL.

The next time it happens, I will disable the other 2 accounts, and show logs of just that one.

Gajim 0.13.4

ouïe, old version! Gajim 0.13.4 is 17 months old!

We won't release any Gajim version in 0.13 branch. Please try 0.14.4, or even 0.15-alpha1 and don't hesitate to re-open if you can reproduce in one of these branches

Note: See TracTickets for help on using tickets.