Opened 5 years ago

Closed 5 years ago

#6095 closed defect (wontfix)

Traceback when cleaning the list of transferred files

Reported by: Dicson Owned by:
Priority: normal Milestone:
Component: Gtkgui Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

[01:08:15] Ozzy: Traceback (most recent call last):

File "/home/igor/gajim/src/filetransfers_window.py", line 655, in on_transfers_list_motion_notify_event

file_props = self.files_props[sid[0]][sid[1:]]

KeyError?: u'17409488'

I hope the attached patch fixes this bug, but I could not reproduce this bug. Other ideas?

Attachments (1)

gajim.vc.diff (1.9 KB) - added by Dicson 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Dicson

comment:1 follow-up: Changed 5 years ago by asterix

  • Status changed from new to needinfo

hmm I'm not able to reproduce ... And I don't think the attached patch will really fix the problem, and it's not a good solution to disconnect signal when there are no row.

Can reporter reproduce? How?

Which kind of transfer was it? socks5? IBB?

comment:2 in reply to: ↑ 1 Changed 5 years ago by Dicson

Replying to asterix:

and it's not a good solution to disconnect signal when there are no row.

no. patch disables the signal at a time when there is a cleaning transfers_list

Can reporter reproduce? How?

no

Which kind of transfer was it? socks5? IBB?

default

reporter received a lot of files. transmission has stopped. He pressed the button and got a traceback

comment:3 Changed 5 years ago by Dicson

  • Resolution set to wontfix
  • Status changed from needinfo to closed

It is unlikely that this bug will be able to reproduce

Note: See TracTickets for help on using tickets.