Opened 6 years ago

Closed 5 years ago

#6036 closed defect (invalid)

Complains of invalid character in hostname

Reported by: https://www.google.com/accounts/o8/id?id=AItOawlXVXZDprV3j73nVgE8C27Ak8DOBkYA_xo Owned by:
Priority: normal Milestone:
Component: None Version:
Severity: normal Keywords: invalid character, hostname
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

Traceback (most recent call last):

File "/usr/share/gajim/src/common/xmpp/idlequeue.py", line 497, in _process_events

return IdleQueue?._process_events(self, fd, flags)

File "/usr/share/gajim/src/common/xmpp/idlequeue.py", line 367, in _process_events

obj.pollin()

File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 405, in pollin

self._do_receive()

File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 585, in _do_receive

self._on_receive(received)

File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 597, in _on_receive

self.on_receive(data)

File "/usr/share/gajim/src/common/xmpp/dispatcher_nb.py", line 445, in dispatch

handlerfunc?(session, stanza)

File "/usr/share/gajim/src/common/connection_handlers.py", line 1197, in _IqCB

self._getRoster()

File "/usr/share/gajim/src/common/connection_handlers.py", line 2582, in _getRoster

self.discover_ft_proxies()

File "/usr/share/gajim/src/common/connection_handlers.py", line 2588, in discover_ft_proxies

self.server_resource)

File "/usr/share/gajim/src/common/helpers.py", line 99, in parse_jid

return prep(*decompose_jid(jidstring))

File "/usr/share/gajim/src/common/helpers.py", line 151, in prep

raise InvalidFormat?, _('Invalid character in hostname.')

InvalidFormat?: Invalid character in hostname.

Steps to reproduce

open gajim. (config file info- i have three hosts set up, the default local one, one with hostname=mail.jaars.org (a corporate server) and another with hostname=talk.google.com) Frankly, I'm not sure what is wrong, and the client seems to work. Because it spit out this error, I thought I should send it in. while the jaars server does work, the google one is spotty -- maybe the problem is there.

Software versions

OS version: Lucid
GTK version:
PyGTK version:

Attachments (1)

gajim.errors.txt (79.9 KB) - added by https://www.google.com/accounts/o8/id?id=AItOawlXVXZDprV3j73nVgE8C27Ak8DOBkYA_xo 6 years ago.
output of gajim -v

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by asterix

  • Status changed from new to needinfo

Could you run "gajim -v" and attach the output here so we can see what really happens?

Changed 6 years ago by https://www.google.com/accounts/o8/id?id=AItOawlXVXZDprV3j73nVgE8C27Ak8DOBkYA_xo

output of gajim -v

comment:2 Changed 6 years ago by https://www.google.com/accounts/o8/id?id=AItOawlXVXZDprV3j73nVgE8C27Ak8DOBkYA_xo

fyi, the last run (for the attachment) I set hostname=google.com, though it didn't seem to make a difference. I have an idea what might be happening, since I got a similar error later, when trying to change this back through the GUI (not the config editor). In addition to invalid character in hostname, it also says "Invalid Jabber ID". both of these sites use an entire Email address (name@host) as login, so there is two @ symbols in the jabber id -- perhaps it is parsing the first @ as the username@jabberserver divider, and not part of the username, which it is -- leaving the second @ in the middle of the jabberserver hostname, which I can imagine would be a problem. Is there some way to make this distinction clear to the client?

comment:3 Changed 6 years ago by asterix

Thanks for the debug output.

Could you edit the /usr/share/gajim/src/common/connection_handlers.py file, and modify it line 2587 to add a print line like that:

cfg_proxies = gajim.config.get_per('accounts', self.name,
    'file_transfer_proxies')
print gajim.get_jid_from_account(self.name), self.server_resource
our_jid = helpers.parse_jid(gajim.get_jid_from_account(self.name) + \
    '/' + self.server_resource)

And show me what is printed in console just before the traceback?

comment:4 Changed 5 years ago by asterix

  • Resolution set to invalid
  • Status changed from needinfo to closed

Please reopen with requested information. You must have a wrong filetransfer proxy configure.

Note: See TracTickets for help on using tickets.