Opened 6 years ago

Closed 6 years ago

#5981 closed defect (duplicate)

Error when trying to register on jabber server without password

Reported by: dkorzhevin@… Owned by:
Priority: normal Milestone: 0.14.1
Component: None Version: 0.14
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: Unix


Gajim 0.14

OS version: Arch Linux

GTK version: 2.22.0-2

PyGTK version: 2.22.0-1

Error log:

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/gajim/", line 262, in on_okbutton_clicked

self.ok_handler(passph, checked)

File "/usr/lib/python2.7/site-packages/gajim/", line 1234, in on_ok


File "/usr/lib/python2.7/site-packages/gajim/common/", line 2235, in set_password


File "/usr/lib/python2.7/site-packages/gajim/common/xmpp/", line 448, in set_password

hash_username = self._convert_to_iso88591(self.respusername?)

File "/usr/lib/python2.7/site-packages/gajim/common/xmpp/", line 431, in _convert_to_iso88591

string = string.decode('utf-8').encode('iso-8859-1')

AttributeError?: 'NoneType?' object has no attribute 'decode'

Change History (2)

comment:1 Changed 6 years ago by asterix

  • Status changed from new to needinfo

this traceback doesn't occure when registering an account, but when you try to register it seems.

I'm not able to reproduce it. Can you? Could you tell us how?

comment:2 Changed 6 years ago by asterix

  • Resolution set to duplicate
  • Status changed from needinfo to closed

dup of #5722

Note: See TracTickets for help on using tickets.