Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5891 closed defect (fixed)

Pop-up error when chatting

Reported by: kianby@… Owned by:
Priority: normal Milestone: 0.14.1
Component: chat Version: 0.14
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

Steps to reproduce

Software versions

OS version:Linux kianby-toshi 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 17:14:28 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz GenuineIntel? GNU/Linux


GTK version: gtk2 2.20.1-2
PyGTK version:pygtk 2.17.0-2

Happens randomly when chatting. No crash but popup following error:

Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/idlequeue.py", line 528, in _process_events

return IdleQueue?._process_events(self, fd, flags)

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/idlequeue.py", line 393, in _process_events

obj.pollin()

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/transports_nb.py", line 414, in pollin

self._do_receive()

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/transports_nb.py", line 600, in _do_receive

self._on_receive(received)

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/transports_nb.py", line 614, in _on_receive

self.on_receive(data)

File "/usr/lib/python2.6/site-packages/gajim/common/xmpp/dispatcher_nb.py", line 452, in dispatch

handlerfunc?(session, stanza)

File "/usr/lib/python2.6/site-packages/gajim/common/protocol/caps.py", line 53, in _capsPresenceCB

self._update_client_caps_of_contact(jid, client_caps)

File "/usr/lib/python2.6/site-packages/gajim/common/protocol/caps.py", line 66, in _update_client_caps_of_contact

contact = self._get_contact_or_gc_contact_for_jid(jid)

File "/usr/lib/python2.6/site-packages/gajim/common/protocol/caps.py", line 73, in _get_contact_or_gc_contact_for_jid

contact = gajim.contacts.get_contact_from_full_jid(self._account, jid)

File "/usr/lib/python2.6/site-packages/gajim/common/contacts.py", line 317, in get_contact_from_full_jid

return self._accounts[account].contacts.get_contact_from_full_jid(fjid)

KeyError?: u'gmail.com'

Change History (5)

comment:1 follow-up: Changed 6 years ago by asterix

  • Status changed from new to needinfo

Is it possible that you renamed your account since you started Gajim?

comment:2 Changed 6 years ago by kianby@…

Today I have updates Gajim but I have added my GMail account too. Two changes ... difficult to diagnose.

comment:3 in reply to: ↑ 1 Changed 6 years ago by kianby@…

Replying to asterix:

Is it possible that you renamed your account since you started Gajim?

You're right. I have renamed account name "gmail.com" to "kianby@…". Deleting and creating again account error disappears :-)

comment:4 Changed 6 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from needinfo to closed

(In [435491862471]) fix changing account name. Fixes #5891

comment:5 Changed 6 years ago by Yann Leboulanger <asterix@…>

  • Milestone changed from 0.15 to 0.14.1

(In [b5703ff5c457]) fix changing account name. Fixes #5891

Note: See TracTickets for help on using tickets.