Opened 6 years ago

Closed 6 years ago

#5757 closed defect (fixed)

Wrong PubSub behaviour

Reported by: Owned by:
Priority: low Milestone: 0.14
Component: notifications Version:
Severity: minor Keywords:
Cc: Blocked By:
Blocking: OS: All


Bug description

Gajim should check the namespace of PubSub? notifications received.

Steps to reproduce

Receive a <entry xmlns="blah"/> PubSub? notification. A notification of the entry (and a traceback) appears.

Correct behaviour

This message should be ignored, because the namespace isn’t known.

Change History (1)

comment:1 Changed 6 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.14
  • Resolution set to fixed
  • Status changed from new to closed

(In [ef758321c654]) check that pubsub messages have a Atom namespace before presenting them to the user. Fixes #5757

Note: See TracTickets for help on using tickets.