Opened 6 years ago

Closed 6 years ago

#5729 closed defect (fixed)

I don't see a lot of contacts

Reported by: https://launchpad.net/~mgol Owned by:
Priority: highest Milestone: 0.14
Component: None Version: hg
Severity: blocker Keywords:
Cc: mgol86@… Blocked By:
Blocking: OS: All

Description

Bug description

From one of my servers - jabster.pl - I see in roster only ONE contact; no transports, no nothing.

Steps to reproduce

I don't know - with Gmail it works fine, with Jabster - not (it's a new problem, it has maybe a few days). I have both of them set in the same Gajim instance.

Software versions

OS version: Ubuntu 10.04 Lucid Lynx amd64
GTK version: 2.20.0
PyGTK version: 2.17.0

Change History (8)

comment:1 Changed 6 years ago by asterix

without more info it will be hard to debug. Maybe XML logs when you connect could help.

comment:2 Changed 6 years ago by https://launchpad.net/~mgol

Where can I send my logs? I don't want to upload them publicly due to massive load of private data (like roster list) that shouldn't be available to everyone.

comment:3 Changed 6 years ago by https://launchpad.net/~mgol

  • Cc https://launchpad.net/~mgol added

comment:4 Changed 6 years ago by asterix

send it to me, I'll keep it private

comment:5 Changed 6 years ago by m_gol

  • Cc mgol86@… added

comment:6 Changed 6 years ago by https://launchpad.net/~mgol

  • Cc https://launchpad.net/~mgol removed

comment:7 Changed 6 years ago by asterix

it's because of roster versionning, and database has maybe been removed. So we should maybe check if there is 0 contact in database, and in this case reset the roster_version ID in config file wso we request the full roster.

comment:8 Changed 6 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.14
  • Resolution set to fixed
  • Status changed from new to closed

(In [d5831792dc48]) request full roster if we have no contacts in our current database, in case we cleaned database but not roster_version option. Fixes #5729

Note: See TracTickets for help on using tickets.