Opened 6 years ago

Closed 6 years ago

#5709 closed defect (fixed)

Can't open configuration account windows

Reported by: cam.lafit Owned by:
Priority: normal Milestone: 0.14
Component: Gtkgui Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

On opening Account configuration via Contextual menu > Modify Account

Traceback (most recent call last):
  File "/var/opt/gajim/src/config.py", line 1643, in on_accounts_treeview_cursor_changed
    self.init_account()
  File "/var/opt/gajim/src/config.py", line 1692, in init_account
    self.init_normal_account()
  File "/var/opt/gajim/src/config.py", line 1820, in init_normal_account
    self.xml.get_widget('cert_entry1').set_text(client_cert)
AttributeError: 'gtk.Builder' object has no attribute 'get_widget'

Steps to reproduce

Software versions

OS version: Lucid Beta
GTK version:
PyGTK version:

Change History (5)

comment:1 Changed 6 years ago by ts33kr

  • Resolution set to fixed
  • Status changed from new to closed

It has already been fixed, in the default branch. Update your HG repository.

comment:2 Changed 6 years ago by ts33kr

Mind though, that it is fixed in the default branch. If you are using a gajim_0.13 branch - then you should switch to the default one, as it looks like you have quite a recent version of GTK+/PyGTK.

comment:3 Changed 6 years ago by cam.lafit

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi

I follow only default branch, i have just update last week end my ubuntu to lucid distribution.

apt-cache policy python gtk2 tell me 2.6.5-0ubuntu1 0 apt-cache policy libgtk2.0-0 tell 2.20.0-0ubuntu4 0

I do update to lasted revision, i haven't alert bug, but configuration account window is empty. I show only accounts list on the left. Right part is empty.

If i launch from a console i see this :

Traceback (most recent call last):
  File "/var/opt/gajim/src/config.py", line 1643, in on_accounts_treeview_cursor_changed
    self.init_account()
  File "/var/opt/gajim/src/config.py", line 1692, in init_account
    self.init_normal_account()
  File "/var/opt/gajim/src/config.py", line 1820, in init_normal_account
    self.xml.get_widget('cert_entry1').set_text(client_cert)
AttributeError: 'gtk.Builder' object has no attribute 'get_widget'

comment:4 Changed 6 years ago by ts33kr

Hm, indeed. This is the very recent changes I missed. Will fix in a moment.

comment:5 Changed 6 years ago by Alexander Cherniuk <ts33kr@…>

  • Milestone set to 0.14
  • Resolution set to fixed
  • Status changed from reopened to closed

(In [c3693e47feae]) gtk.Builder.get_widget is now known as gtk.Builder.get_object. Fixes #5709

Note: See TracTickets for help on using tickets.