Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5574 closed defect (fixed)

client does not connect one of two accounts programistic error has been detected, unusable account

Reported by: winner5 Owned by:
Priority: normal Milestone: 0.13.4
Component: roster Version: 0.13.2
Severity: normal Keywords:
Cc: winner5@… Blocked By:
Blocking: OS: All

Description

Gajim do not connect one of my two accounts and the window 'wykryto błąd programistyczny' (probably 'programistic bug has been detected' in English) appears: that's the content: Traceback (most recent call last):

File "/usr/local/share/gajim/src/common/xmpp/idlequeue.py", line 497, in _process_events

return IdleQueue?._process_events(self, fd, flags)

File "/usr/local/share/gajim/src/common/xmpp/idlequeue.py", line 367, in _process_events

obj.pollin()

File "/usr/local/share/gajim/src/common/xmpp/transports_nb.py", line 405, in pollin

self._do_receive()

File "/usr/local/share/gajim/src/common/xmpp/transports_nb.py", line 585, in _do_receive

self._on_receive(received)

File "/usr/local/share/gajim/src/common/xmpp/transports_nb.py", line 597, in _on_receive

self.on_receive(data)

File "/usr/local/share/gajim/src/common/xmpp/client_nb.py", line 293, in <lambda>

self.onreceive(lambda _data:self._xmpp_connect_machine(mode, _data))

File "/usr/local/share/gajim/src/common/xmpp/client_nb.py", line 343, in _xmpp_connect_machine

self._xmpp_connect_machine(mode='STREAM_STARTED')

File "/usr/local/share/gajim/src/common/xmpp/client_nb.py", line 346, in _xmpp_connect_machine

self._on_stream_start()

File "/usr/local/share/gajim/src/common/xmpp/client_nb.py", line 354, in _on_stream_start

self.onreceive(None)

AttributeError?: NonBlockingClient? instance has no attribute 'onreceive'

Attachments (3)

gajim-v.txt (146.6 KB) - added by winner5 7 years ago.
gajim -v, bug did not appeared, pass-asking window disappears before I finish or even start typing the pass
gajim-0.13.2-noerror(po eroorze bez -v)-zrzut3.tzt (106.0 KB) - added by winner5 7 years ago.
0.13.2 after error displayed without -v option, containing log without error displayed
gajim.log-errorreproducedin0.13.10.2-dev (38.1 KB) - added by winner5 7 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 7 years ago by asterix

  • Keywords client do not connect one of two acounts programistic bug detected removed
  • Priority changed from high to normal

you didn't filled the OS field, but I guess it's linux. Could you run gajim -v from a console to see what happens?

comment:2 Changed 7 years ago by winner5

http://trac.gajim.org/wiki/HowToCreateATicket says:

"OS

If you are reporting something which is limited to only one OS, select it in the list."

I cannot tell if it is limited only to linux.

I use Ubuntu 9.10, kernel: 2.6.31-18-generic

The error appears not every time I use Gajim, when I ran Gajim without existing '~/.gajim/' directory it happenned: http://trac.gajim.org/ticket/5576

comment:3 Changed 7 years ago by winner5

I will try to find out how to repeat the bug appearance and then I will run gajim -v and cause the bug again.

comment:4 Changed 7 years ago by asterix

  • Status changed from new to needinfo

and when you opened the ticket it was pre-filled by asking you some info (Os, gtk and pygtk version)

but ok, we really need debug info when you can reproduce the bug

comment:5 Changed 7 years ago by winner5

gajim -v: The bug did no appeared, but when the client was asking for passwords it did no wait for me to type it. I think that it is necessary for the bug to appear that second account has incorrect JID: account2@… and correct server talk.google.com, standard port. The error was exactly the same as one I posted weeks ago, but it was on verson 12.5. The bug still appears on this version. It looks the same (I did not analyze it exactly). On 0.13.2 and 0.13.1 this time (before it happenned often) password-asking dialog window disappears before I type the pass. I noticed that in accounts settings non-gmail (let's call it account1) has set empty, but saved in settings password. I still try.

(and when you opened the ticket it was pre-filled by asking you some info (Os, gtk and pygtk version) I think that it did not ask about GTK and PyGTK versions...

Changed 7 years ago by winner5

gajim -v, bug did not appeared, pass-asking window disappears before I finish or even start typing the pass

comment:6 Changed 7 years ago by winner5

'gajim' outputs in console:

gajim.py:3680: Warning: g_set_prgname() called multiple times

gnome.program_init('gajim', gajim.version)

Is it important?

Error stil not reachable. Can I paste gajim -v of version 0.12.5 (error looked the same)?

comment:7 Changed 7 years ago by winner5

That is similar error in 0.12.5 (the same '~/.gajim/' directory content!) http://trac.gajim.org/ticket/5320

comment:8 follow-up: Changed 7 years ago by asterix

gajim -v just add some output, it should not change the behaviour of windows...

your debug output shows connection to more than one account, so it's hard to keep only what interests the bug, and there is no traceback in this log. Please run gajim -v > gajim.log 2>&1 to put traceback in log file too. and 0.12.5 and 0.13 have many changes in connection process, so I doubt it will be usefull.

Does it only happen when you enter a wrong jid (@talk.google.com)?

I cannot reproduce here with this wrong jid

comment:9 Changed 7 years ago by winner5

I reproduced the error this morning, but unfortunately without -v option. I am still trying, this time alwayes with -v. But I noticed that Gajim 0.12.5 with -v does not apeear the error window, but it is present in the console as trackback. I have this 0.12.5 -v log (without error window displayed). And I attach the log wihout error window in 0.13.2 version (after error displayed without -v)

Changed 7 years ago by winner5

0.13.2 after error displayed without -v option, containing log without error displayed

comment:10 in reply to: ↑ 8 Changed 7 years ago by winner5

Does it only happen when you enter a wrong jid (@talk.google.com)?

I think that it can be important, I am still investigating it. But today morning I repeated the bug. 5 minutes ago I did it again. Unfortunately wothout -v option only...

comment:11 Changed 7 years ago by winner5

I changed some accounts options, restred Gajim and:

Logger gajim level set to 1 18:09:11 (I) gajim.c.x.tls_nb PyOpenSSL loaded 18:09:15 (D) gajim.c.z.connection_handlers_zeroconf Nie można załadować modułu idle 18:09:15 (D) gajim.c.resolver Import of libasyncns-python failed, getaddrinfo will block Traceback (most recent call last):

File "/usr/local/share/gajim/src/common/resolver.py", line 37, in <module>

import libasyncns

ImportError?: No module named libasyncns 18:09:15 (I) gajim.gajim Encodings: d:utf-8, fs:UTF-8, p:UTF-8 gajim.py:3679: Warning: g_set_prgname() called multiple times

gnome.program_init('gajim', gajim.version)

Traceback (most recent call last):

File "gajim.py", line 3698, in <module>

interface = Interface()

File "gajim.py", line 3516, in init

gajim.connections[account] = common.connection.Connection(account)

File "/usr/local/share/gajim/src/common/connection.py", line 143, in init

self.password = passwords.get_password(name)

File "/usr/local/share/gajim/src/common/passwords.py", line 217, in get_password

return get_storage().get_password(account_name)

File "/usr/local/share/gajim/src/common/passwords.py", line 100, in get_password

self.save_password(account_name, password)

File "/usr/local/share/gajim/src/common/passwords.py", line 128, in save_password

display_name, attributes1, password, update)

TypeError?: item_create_sync() argument 5 must be string, not None Error in atexit._run_exitfuncs: Traceback (most recent call last):

File "/usr/lib/python2.6/atexit.py", line 24, in _run_exitfuncs

func(*targs, kargs)

File "gajim.py", line 392, in on_exit

gajim.interface.roster.prepare_quit()

AttributeError?: Interface instance has no attribute 'roster' Error in sys.exitfunc: Traceback (most recent call last):

File "/usr/lib/python2.6/atexit.py", line 24, in _run_exitfuncs

func(*targs, kargs)

File "gajim.py", line 392, in on_exit

gajim.interface.roster.prepare_quit()

AttributeError?: Interface instance has no attribute 'roster'

No comment.

comment:12 Changed 7 years ago by asterix

this traceback is not from 0.13.2 release I guess ... so fixed in 0.13.2.

comment:13 Changed 7 years ago by winner5

I think that it is, but I cannot be sure. I remember that I used 0.13.(1|2) I changed some account settings and then I closed the app. After that gajim did not run anymore.

comment:14 Changed 7 years ago by asterix

You don't know which version, you don't know which settings you changed, you don't have the traceback anymore ... I think you understand we cannot do anything with so few information ... We need the debug info with the traceback.

comment:15 Changed 7 years ago by winner5

  • Severity changed from major to normal

The error completely disappeared. Maybe it is connected with python packages update in my system. I think that we can ignore that error because it appears very very rarely. And of course only without -v option. The program was quite mean to me. Especially 0.13.x versions.

comment:16 Changed 7 years ago by asterix

  • Resolution set to worksforme
  • Status changed from needinfo to closed

ok don't hesitate to reopen if you have more info

comment:17 Changed 7 years ago by winner5

  • Status changed from closed to needinfo

I used 0.13.10.2-dev version, downloaded from http://www.gajim.org/downloads/snap/gajim-2010-02-10.tar.gz and I finally reproduced the error with -v option! That is gajim.log file, but I cannot see that traceback which is shown in programistic error detected window.... I attach gajim.log as gajim.log-errorreproducedin0.13.10.2-dev

Changed 7 years ago by winner5

comment:18 Changed 7 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.14
  • Resolution changed from worksforme to fixed
  • Status changed from needinfo to closed

(In [152452007c3c]) don't traceback when we get disconnected wile we parse stream features. Fixes #5574

comment:19 Changed 7 years ago by Yann Leboulanger <asterix@…>

  • Milestone changed from 0.14 to 0.13.2

(In [2b4dd2bf4300]) don't traceback when we get disconnected wile we parse stream features. Fixes #5574

comment:20 Changed 7 years ago by asterix

  • Milestone changed from 0.13.2 to 0.13.4
Note: See TracTickets for help on using tickets.