Opened 6 years ago

Closed 5 years ago

#5516 closed defect (worksforme)

An account can be created halfways and give errors when opening Accounts dialog

Reported by: Espen Owned by:
Priority: normal Milestone:
Component: None Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

I wanted to create an account and somehow didn't complete the process. The account is left in the list (Shift-Ctrl-A) but when I press the account name to delete or activate it, I get this error:

when deleting Traceback (most recent call last):

File "/usr/lib64/python2.6/site-packages/gajim/config.py", line 1678, in on_remove_button_clicked

for key in gajim.interface.instances[account]:

KeyError?: u'x.x.x.x'

when opening: Traceback (most recent call last):

File "/usr/lib64/python2.6/site-packages/gajim/config.py", line 1454, in on_accounts_treeview_cursor_changed

self.init_account()

File "/usr/lib64/python2.6/site-packages/gajim/config.py", line 1487, in init_account

self.init_normal_account()

File "/usr/lib64/python2.6/site-packages/gajim/config.py", line 1626, in init_normal_account

if gajim.connections[account].gpg:

KeyError?: u'x.x.x.x'

Where the x.x.x.x is my IP address (the name of the account).

Steps to reproduce

I have no idea what I did to mess up the account, but I think I clicked cancel along the way.

Software versions

OS version: linux 2.6.29
GTK version: 2.16.6
PyGTK version: 2.14.1

Change History (2)

comment:1 Changed 6 years ago by asterix

  • Status changed from new to needinfo

which version is it? I'm not able to reproduce something like that in latest version

comment:2 Changed 5 years ago by asterix

  • Resolution set to worksforme
  • Status changed from needinfo to closed
Note: See TracTickets for help on using tickets.