Opened 7 years ago

Closed 7 years ago

#5497 closed defect (invalid)

Strange sorting of roster in 0.13.1

Reported by: Grzegorz Janoszka Owned by:
Priority: normal Milestone:
Component: roster Version: 0.13.1
Severity: normal Keywords: sort roster
Cc: Blocked By:
Blocking: OS: Windows

Description

Bug description

I have been using gajim for some time. I have one jabber acount, but most of my contacts are via one of transports. All gajims 0.12.X properly sorted my roster, gajim 0.13.1 has strange sorting.

Steps to reproduce

Just open roster on gajim

Software versions

OS version: Windows 7 GTK version: ?? PyGTK version: ??

Attachments (1)

gajim.png (11.6 KB) - added by Grzegorz Janoszka 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Grzegorz Janoszka

comment:1 Changed 7 years ago by Grzegorz Janoszka

I attached a file showing my roster. First and last contacts have "available" status, the ones in the medium have different - not available, disconnected, offline etc. Of course 'sort roster by status' is checked.

comment:2 Changed 7 years ago by asterix

  • Resolution set to invalid
  • Status changed from new to closed

I guess it's because you haven't gave those contacts authorization to see you online, so they always see you offline. And indeed Gajim put them at the end of your roster. To be sure, open information dialog for those contacts, and look at the "subscription" value in the "more" expander.

To fix this authorization issue, they have to request your authorization and thn you can accept to send them your status.

Note: See TracTickets for help on using tickets.