Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5419 closed defect (fixed)

Missing PyOpenSsl Warning Buttons has no effects (Traceback)

Reported by: eMerzh Owned by:
Priority: normal Milestone: 0.13
Component: None Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Bug description

I get the Rc5 from hg and try to connect to my gmail account. But i've forget to install pyOpenSsl... and a warning message shows up.

But there is no action when you click on a button (cancel or submit)...

In a console it shows a traceback

Traceback (most recent call last):
  File "/home/emerzh/Code/gajim/src/dialogs.py", line 1547, in on_response_cancel
    self.user_response_cancel()
  File "/home/emerzh/Code/gajim/src/gui_interface.py", line 1967, in on_cancel
    del self.instances[account]['online_dialog']['insecure_ssl']
KeyError: 'insecure_ssl'
Traceback (most recent call last):
  File "...gajim/src/dialogs.py", line 1539, in on_response_ok
    self.user_response_ok(self.is_checked())
  File "/home/emerzh/Code/gajim/src/gui_interface.py", line 1953, in on_ok
    on_cancel()
  File "...gajim/src/gui_interface.py", line 1967, in on_cancel
    del self.instances[account]['online_dialog']['insecure_ssl']
KeyError: 'insecure_ssl'

Steps to reproduce

Try to connect to an account without pyopenssl

Software versions

OS version: ArchLinux? With 2.6.31

GTK version: 2.16.0 PyGTK version: 2.16.0

Change History (5)

comment:1 Changed 7 years ago by asterix

I cannot reproduce, all work fine here.

Note: You didn't use rc5 but hg version, it's not the same

comment:2 Changed 7 years ago by asterix

  • Milestone 0.13 deleted
  • Status changed from new to needinfo

Can someone reproduce that?

comment:3 Changed 7 years ago by eMerzh

  • Status changed from needinfo to new

i've try to switch branche with

hg update -C gajim_0.13

Now gajim shows Version : Gajim 0.12.5.90-rc5

And the pbm is still there..

Traceback (most recent call last):
  File "/home/emerzh/Code/gajim/src/dialogs.py", line 1538, in on_response_ok
    self.user_response_ok(self.is_checked())
  File "gajim.py", line 2249, in on_ok
    on_cancel()
  File "gajim.py", line 2263, in on_cancel
    del self.instances[account]['online_dialog']['insecure_ssl']
KeyError: 'insecure_ssl'

comment:4 Changed 7 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.14
  • Resolution set to fixed
  • Status changed from new to closed

(In [9b9cd15a280e]) Don't clean dict twice, Fixes #5419

comment:5 Changed 7 years ago by Yann Leboulanger <asterix@…>

  • Milestone changed from 0.14 to 0.13

(In [1001e93ec906]) Don't clean dict twice, Fixes #5419

Note: See TracTickets for help on using tickets.