Opened 7 years ago

Closed 7 years ago

#5261 closed defect (fixed)

Traceback when closing chat window

Reported by: http://plisk.livejournal.com/ Owned by:
Priority: high Milestone:
Component: chat Version: hg
Severity: critical Keywords:
Cc: michael@… Blocked By:
Blocking: #5227 OS: All

Description

Traceback (most recent call last):
  File "/usr/share/gajim/src/message_window.py", line 409, in _on_close_button_clicked
    self.remove_tab(control, self.CLOSE_CLOSE_BUTTON)
  File "/usr/share/gajim/src/message_window.py", line 529, in remove_tab
    ctrl.allow_shutdown(method, on_yes, on_no, on_minimize)
  File "/usr/share/gajim/src/chat_control.py", line 2346, in allow_shutdown
    [self.get_full_jid()] < 2:
KeyError: u'urykhy@jabber.ru/work'

Change History (7)

comment:1 Changed 7 years ago by m_gol

At me it's a bit different:

Traceback (most recent call last):
  File "/home/mgol/gajim/src/message_window.py", line 301, in on_tab_eventbox_button_press_event
    self.remove_tab(ctrl, self.CLOSE_TAB_MIDDLE_CLICK)
  File "/home/mgol/gajim/src/message_window.py", line 529, in remove_tab
    ctrl.allow_shutdown(method, on_yes, on_no, on_minimize)
  File "/home/mgol/gajim/src/chat_control.py", line 2361, in allow_shutdown
    on_yes(self)
  File "/home/mgol/gajim/src/message_window.py", line 513, in on_yes
    close(ctrl)
  File "/home/mgol/gajim/src/message_window.py", line 504, in close
    del self._controls[ctrl.account][fjid]
KeyError: u'janek37@jabster.pl/Gajim'

BTW, I cannot close Gajim at all, too.

comment:2 Changed 7 years ago by asterix

I think I know why ... I'll have to try to fix all that. it's because of ths commit I did for #5227

comment:3 Changed 7 years ago by meekstone@…

The problem is more than just a traceback on closing a chat window. In some cases (I could not reproduce it), the chat window disappears and the traceback is shown, but Gajim seems to keep the chat "opened". It is not possible to open a chat with the contact for which you just tried to close the chat window until you completely shut down Gajim. Chat messages received in this state are lost if you do not have history logging enabled, because they are never shown.

comment:4 Changed 7 years ago by m_gol

  • Priority changed from normal to high
  • Severity changed from normal to critical

Messages losing issue seems to be of critical severity, so I bump the severity and priority. If you don't agree, just change it back.

comment:5 Changed 7 years ago by michael@…

  • Cc michael@… added

comment:6 Changed 7 years ago by asterix

  • Blocking 5227 added

comment:7 Changed 7 years ago by asterix

  • Resolution set to fixed
  • Status changed from new to closed

(In [96bc45dcde7b]) correctly change the resource of a control. Fixes #5261

Note: See TracTickets for help on using tickets.