Opened 7 years ago

Closed 7 years ago

#5171 closed defect (worksforme)

Just tried to go online for the first time and got python traceback

Reported by: mcap@… Owned by:
Priority: normal Milestone:
Component: None Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: Unix

Description

I just installed the ubuntu package, created my account and then tried to go online with it. I got an error window with the following traceback:


Traceback (most recent call last):

File "gajim.py", line 463, in _process_events

return self.process_events(fd, flags)

File "/usr/share/gajim/src/common/xmpp/idlequeue.py", line 132, in process_events

obj.pollin()

File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 352, in pollin

self._do_receive()

File "/usr/share/gajim/src/common/xmpp/transports_nb.py", line 502, in _do_receive

self.on_receive(received)

File "/usr/share/gajim/src/common/xmpp/client_nb.py", line 166, in _on_receive_document_attrs

self.onreceive(None)

AttributeError?: NonBlockingClient? instance has no attribute 'onreceive'

Change History (4)

comment:1 Changed 7 years ago by asterix

  • Status changed from new to needinfo

Could you precise the version of Gajim you use?

Could you run "gajim -v -l gajim=DEBUG" from a console and attach the logs here please?

comment:2 Changed 7 years ago by mcap@…

I'm unable to attach log as the website thinks its spam due to external links.

comment:3 Changed 7 years ago by asterix

register an account on trac and you'll be able to attach it

comment:4 Changed 7 years ago by johnny

  • Resolution set to worksforme
  • Status changed from needinfo to closed

reopen if you can reproduce in newest gajim

Note: See TracTickets for help on using tickets.