Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5084 closed defect (fixed)

not work with Google.Talk

Reported by: CatMix Owned by:
Priority: high Milestone: 0.12.3
Component: None Version: 0.12.2
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Hi, I upgraded from 1.12.1 to 1.12.2? He saw that this version does not work with Google, and revert back to 1.12.1 The same settings.

Change History (8)

comment:2 Changed 7 years ago by asterix

  • Milestone 0.12.2 deleted
  • Version set to 0.12.2

could you:

  • Remove gajim.exe.log file in c:\documents and settings\YOUR_ACCOUNT\application data\gajim\
  • run gajim, go in advanced configuration window (preferences -> advanced), enable versino option
  • restart gajim, try to connect to only your gtalk account
  • attache the gajim.exe.log that is in c:\documents and settings\YOUR_ACCOUNT\application data\gajim\ (eventualy zipped)

comment:4 Changed 7 years ago by vArDo

Logs from verbose mode: http://gajim.pastebin.com/f2977540e . Version from Hg repo with tag 'gajim-0.12.2'.

As described in ticket - auth fails. There's no such problem on default branch.

comment:5 Changed 7 years ago by vArDo

OK. Fixed. There was a one-letter typo :] I'll post details in a couple of minutes.

comment:6 Changed 7 years ago by vArDo

Here's the trouble-maker changeset: http://trac.gajim.org/changeset/10452:09796839e2be/src/common/xmpp/auth_nb.py

Since then @line 165 there was:

asl_data = sasl_data.encode('utf-8').encode('base64').replace(

instead of:

sasl_data = sasl_data.encode('utf-8').encode('base64').replace(

This caused base64 _never_ to be applied for password.

Will be fixed soon.

comment:7 Changed 7 years ago by vArDo

  • OS changed from Windows to All

comment:7 Changed 7 years ago by vardo

  • Milestone set to 0.12.2
  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 7 years ago by asterix

  • Milestone changed from 0.12.2 to 0.12.3
Note: See TracTickets for help on using tickets.