Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#4900 closed defect (fixed)

A programming error has been detected.

Reported by: anonymous Owned by:
Priority: normal Milestone: 0.14.2
Component: None Version: 0.14.1
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

I just wanted to join a room from my bookmarks and poof!

Traceback (most recent call last):

File "/usr/share/gajim/src/roster_window.py", line 2309, in on_bookmark_menuitem_activate

bookmarkpassword?)

File "gajim.py", line 2657, in join_gc_room

gajim.connections[account].join_gc(nick, room_jid, password)

File "/usr/share/gajim/src/common/connection.py", line 1541, in join_gc

last_log = gajim.logger.get_room_last_message_time(room_jid)

File "/usr/share/gajim/src/common/logger.py", line 659, in get_room_last_message_time

jid_id = self.get_jid_id(jid, 'ROOM')

File "/usr/share/gajim/src/common/logger.py", line 209, in get_jid_id

self.cur.execute('SELECT jid_id FROM jids WHERE jid=?', [jid])

ProgrammingError?: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.

Change History (6)

comment:1 Changed 7 years ago by steve-e

What does "locale" yield on your box?

comment:2 Changed 7 years ago by johnny

  • Status changed from new to needinfo

comment:3 Changed 7 years ago by johnny

  • Resolution set to worksforme
  • Status changed from needinfo to closed

reopen if you can reproduce

comment:4 Changed 5 years ago by Animus

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version set to 0.14.1

looks like I have same error

it is happens when working with MUC jids in 'Join Group Chat' containing utf-8 characters (at least russian ones e.g. вио@conference.jabber.ru)

Traceback (most recent call last):
  File "/usr/share/gajim/src/roster_window.py", line 2453, in on_bookmark_menuitem_activate
    bookmark['password'])
  File "/usr/share/gajim/src/gui_interface.py", line 2710, in join_gc_room
    gajim.connections[account].join_gc(nick, room_jid, password)
  File "/usr/share/gajim/src/common/connection.py", line 2040, in join_gc
    last_log = gajim.logger.get_room_last_message_time(room_jid)
  File "/usr/share/gajim/src/common/logger.py", line 730, in get_room_last_message_time
    jid_id = self.get_jid_id(jid, 'ROOM')
  File "/usr/share/gajim/src/common/logger.py", line 228, in get_jid_id
    self.cur.execute('SELECT jid_id FROM jids WHERE jid=?', [jid])
ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.

on the first look, before this error, everything looks ok. but in some moments above listed error happens. and after it happens, new error occurs if trying to do something with this MUC room

Traceback (most recent call last):
  File "/usr/share/gajim/src/roster_window.py", line 2453, in on_bookmark_menuitem_activate
    bookmark['password'])
  File "/usr/share/gajim/src/gui_interface.py", line 2702, in join_gc_room
    gc_control.nick = nick
AttributeError: 'NoneType' object has no attribute 'nick'

if trying to close room with utf-8 jid after error:

Traceback (most recent call last):
  File "/usr/share/gajim/src/message_window.py", line 247, in _on_window_delete
    on_minimize)
  File "/usr/share/gajim/src/groupchat_control.py", line 1736, in allow_shutdown
    on_minimize(self)
  File "/usr/share/gajim/src/message_window.py", line 237, in on_minimize
    ctrl.minimize()
  File "/usr/share/gajim/src/groupchat_control.py", line 1663, in minimize
    ctrl_page = win.notebook.page_num(ctrl.widget)
AttributeError: 'NoneType' object has no attribute 'widget'

comment:5 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone set to 0.15
  • Resolution set to fixed
  • Status changed from reopened to closed

(In [93dfb89ebcf6]) correctly decode sting in manage bookmarks dialog. Fixes #4900

comment:6 Changed 5 years ago by Yann Leboulanger <asterix@…>

  • Milestone changed from 0.15 to 0.14.2

(In [c140243c9c72]) correctly decode sting in manage bookmarks dialog. Fixes #4900

Note: See TracTickets for help on using tickets.