Opened 8 years ago

Closed 8 years ago

#4524 closed defect (fixed)

Deleting wrong Item in Buddylist

Reported by: pat Owned by: steve-e
Priority: normal Milestone: 0.12
Component: roster Version: hg
Severity: normal Keywords: delete, roster
Cc: Blocked By:
Blocking: OS: All

Description

When I delete an observer with the same JID as someone I already got in my roster(Shouldn't the observer disappear, when giving(& getting) Subscription?), the contact I already got in my roster get deleted instead of the observer.

Change History (4)

comment:1 Changed 8 years ago by steve-e

Hi,

can you please describe how you made this contact become an observer? I have spotted several bugs by now but could not find the way to reproduce, yet.

@others Help really appreciated here, because I am not really into the req/sub code.

comment:2 Changed 8 years ago by asterix

to have an observer, you remove it from your roster, and you check the checkbutton "let the user see my status"

But indeed when you get his auth, the line in observer must disappear.

It's a bug if you have 2 lines with the same jid. I'll try to repro that this evening

comment:3 Changed 8 years ago by steve-e

(In [8c545a8d4dba3fdc8e30b4513a631e5f1d88becf]) Correctly remove Observer and NotInRoster? contact in one special case. Does not affect pending bug. See #4524.

comment:4 Changed 8 years ago by steve-e

  • Resolution set to fixed
  • Status changed from new to closed

(In [708e01bbaef974d7b868fdca312d1a0e4c260c58]) Do not duplicate a contact in roster on subscription changes. Fixes #4524.

For performance reasons, get_contact_iters() cannot find a contact if get_shown_groups() returns something different to what has been applied to roster model. The contact was therefore duplicated as it was believed not to be there...

Note: See TracTickets for help on using tickets.