Opened 7 years ago

Closed 7 years ago

#4494 closed defect (worksforme)

PEP doesn't update properly

Reported by: Dag Owned by:
Priority: normal Milestone: 0.12
Component: None Version: hg
Severity: major Keywords: pep pubsub tune mood activity
Cc: Blocked By:
Blocking: OS: All

Description

Not sure which side the issue is at, but the screenshot says it all. Mood and Activity which I set in an earlier session is not sent to my test account, but Tune is which has been updated during this session. I also tested setting Activity and it got displayed in the test account, Mood still not showing.

Attachments (1)

Gajim.png (18.8 KB) - added by Dag 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Dag

comment:1 Changed 7 years ago by Dag

  • Keywords pep pubsub tune mood activity added
  • Milestone set to 0.12
  • Severity changed from normal to major
  • Version set to svn

I hope you don't miss this one because I accidently double-posted and closed #4493. This one is still open! :)

Increasing severity because this potentially makes PEP silent in/from Gajim clients.

comment:2 Changed 7 years ago by steve-e

Which server version do you use?

comment:3 Changed 7 years ago by Dag

Which server version do you use?

I suppose it could well be a server-side issue. I've heard the ejabberd pubsub implementation is lacky.

xepbot: Dag: im.flosoft.biz's client is ejabberd (version 2.0.1) on unix/linux 2.6.18

comment:4 Changed 7 years ago by steve-e

Could you please verify if you receive your pep information when connecting and when publishing something? You simply have to start gajim with the "-v" option or open the XML console.

We have had similar issues with ejabbered 1.x implementations, because they did not send PEP information back to us. We decided not implemented a client side "fallback" mechanism for restoring a published mood or activity.

comment:5 Changed 7 years ago by Dag

I do in deed receive my PEP information when connecting, it works now - I can't replicate. Weird.

Publishing already worked before.

If others can't replicate either I suppose we can close this.

comment:6 Changed 7 years ago by steve-e

  • Resolution set to worksforme
  • Status changed from new to closed

As it is working for me, I guess we can close this.

Note: See TracTickets for help on using tickets.