Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4436 closed enhancement (fixed)

Wrong behavior of Trayicon at pending messages

Reported by: Sven Owned by:
Priority: normal Milestone: 0.12.2
Component: systray Version: hg
Severity: normal Keywords: systray tray icon pending event message
Cc: Blocked By:
Blocking: OS: Unix

Description

When Gajim receives a new Message it's correctly shown at the tray icon. By clicking on it, it opens the roster windows and NOT the pending message(s) - I think this wasn't your intention.

Right clicking and choosing "show all pending events" works fine.

I use Ubuntu 8.04 but will test this issue later in a windows vm.

Change History (19)

comment:1 Changed 8 years ago by asterix

  • Resolution set to invalid
  • Status changed from new to closed

it's the wanted behaviour. Use middle click to show pending messages

comment:2 follow-up: Changed 8 years ago by Sven

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from defect to enhancement

Oh I didn't mean it in an arrogant way.. :) right it works! but the first message of a beginning conversation must always be opened manually - I think it's not very user friendly.

So what's about getting _all_ pending (message) events when the chat window gets the focus?

comment:3 Changed 8 years ago by asterix

preference window -> notification -> pop it up ?

comment:4 in reply to: ↑ 2 Changed 8 years ago by Jim++

Replying to Sven:

So what's about getting _all_ pending (message) events when the chat window gets the focus?

Then if you already have opened chats tab you will loose information of what tab have new messages.

comment:5 Changed 8 years ago by asterix

  • Resolution set to invalid
  • Status changed from reopened to closed

I didn't understood what Sven meant, but indeed I agree with Jim.

comment:6 Changed 8 years ago by Sven

I didn't see the "pop it up" thing so it's good how it is.

comment:7 Changed 8 years ago by Jim++

preference window -> notification -> When a new event is received -> pop it up

comment:8 Changed 8 years ago by anonymous

Maybe it would be useful to make this behaviour customizable? Was very surprised with it.

comment:9 Changed 8 years ago by asterix

it's because you're used to the old behaviour. Now it seems more consistant to do dubble click or middle click on systray because you do the same in roster.

comment:10 Changed 8 years ago by Andreas Spong

I was suprised about the new "feature" too and I would prefere the old behaviour - an option to switch would be nice, maybe in the advanced editor without a gui element. But it should be costumizable.

In my opinion the old behavior of task icon was perfect. If there is an event - open it with a single click. It's (at least for me) much more intuitive and for me it is a lot faster as hitting middle click. And it is the behaviour all (or mostly all ;-) ) other IMs do - you *do* scare users with the actual behaviour as I recognized the last days with a dozen of installations and furious users. It's what most people I know who using IM do expect from an moving Icon - single left click on it and the cause of it will show. :-)

For consistency reasons: in roster the same should apply: if there is an event - single left click to open an event. And an incomming event is something other than creating a new message so the behaviour can differ without fighting consistency - there can be single click to open an event on the one hand and single click to create a new message/connection on the other.

Would like to see this feature comming back as an option

Just my 2 cent and guys: thanks for this IM, you do a great job!

Andreas

PS: Don't know if talking about this under this ticket is the right place. Maybe a new feature request is better?

comment:11 follow-up: Changed 8 years ago by asterix

Psi, another very popular jabber client, behaves the same way.

I don't think it's a good thing that the behaviour is different depending on the fact that there is a pending event or not.

comment:12 Changed 8 years ago by Sven

What You See Is What You Get is in my opinion more intuitive than "always do the same though the object seems to be in a different state".

comment:13 follow-up: Changed 8 years ago by asterix

indeed you see Gajim icon, so when you click on it, you get gajim window.

Moreover GnomeHIG says to always do the same thing on same object: Gnome HIG

comment:14 in reply to: ↑ 11 Changed 8 years ago by Andreas Spong

Replying to asterix:

Psi, another very popular jabber client, behaves the same way.

Yes, that's true. But I think of a lot of other messengers beside gajim and psi and they do have changing behaviour. That's what people are used to. (Bad argument because they could change there behaviour, I know. But teach a old dog new tricks... and in my opinion software should adapt to users and there behavior and not the oposite.)

I don't think it's a good thing that the behaviour is different depending on the fact that there is a pending event or not.

But it would be possible to (re-)implement it as an option in the deepest corner of the advanced editor gajim for those nasty users who do not agree with you in this. ;-)

comment:15 in reply to: ↑ 13 Changed 8 years ago by anonymous

Replying to asterix:

indeed you see Gajim icon, so when you click on it, you get gajim window.

That is OK, but if there is a message, the gajim icon isn't a static gajim icon but a moving star. So it's another icon and at least I do expect another behaviour from a changed icon.

Moreover GnomeHIG says to always do the same thing on same object: Gnome HIG

from there:

"Consistency enables users to apply their existing knowledge of their computing environment and other applications to understanding a new application."

So there are two user groups. one group is used to have changing behaviour like it is with e.g. miranda or gajim < 0.12 and there is the other group with psi and gajim >= 0.12 behavior.

Let's get them all satisfied with a truly configurable Gajim. :-)

comment:16 Changed 8 years ago by asterix

  • Milestone changed from 0.12 to 0.13
  • Resolution changed from invalid to fixed

(In [867f849de4323245e93a2ab3015ae1721c1da7e0]) restore old behaviour of systray: left click open pending event if any, else hide/show roster. Fixes #4436

comment:17 Changed 8 years ago by Sven

That's awesome!

comment:18 follow-up: Changed 7 years ago by asterix

  • Milestone changed from 0.13 to 0.12.2

(In [09796839e2bebc0da3a07e71d6823348218bda01]) import buxfixes from trunk: [2f6777135ca9837b34547bb42e360298b007befd] [0f5ef6e4c08ba974d038d7e2a2942c48e7f25d90] [9a3ff5f34ceb34492b2d99980eb00a40715bdb39] [63fa81bb3c62abcf1bfaabbe7a7cce61a6635fc3] [0110717d41f431c5332826c8ec4f635755ca0e7d] [7af618813dee11472b1d5d7afd07124a91af38dc] [564c2afcfa031bb671da9bc98a289bf3472f03e9] [889291db9d9eaa70e409e0fa2dcea492d80a0c1f] [71be893da00c5c9150eb1391f301f7d41b835a84] [3be7988bc2ce9fda2ed88123e39699386db1e81b] [793cfcca4ce562c86a555c2722e57565b408fbfb] [01cdc23f51b98a88711d613790f60f2903d1d8c8] [f51231fc0b8620fdb0996f51896c35abff86c7b8] [48585d14b4ab651c525f79bec7b0119398f61e3a] [037f14f8576115508be16804218430ee28ddea3d] [d0f50f05458b2ad8396adad86397d966675a6d9d] [947b3ef29e324ac5a63815b41f8ee0f9281697fa] [d021c6d7aa6bc0386bba394261e019fe820d5529] [46a2ee4f7a9bd6952db03109e30e02de3ce2a51f] [e2180b23b400d1ae08146e75cc4f39b5103da6cf] [446eff894b70c99feff606a0ea2d1a62d84d74dd] [be29c1a61dad46793e9642508e0f2b3acdafdb07] [722476e07db648ce3048c14e0442d2450f3f28fa] [f73baea344b42b7c484a0aacbcd5d65211d28390] [9b7005dee1784c44e9e7c1aaa217071c538800da] [1cf7d971214a25ad45bd9040d72c29cfe481e2ec] [1ae9ed5e32496a993d11d6f24360769644d2da96] [a2d93f05a489519056b951f6401791a394035b55] [0d076db016a74721bc892741797231474901025c] [cdb93d643d96512806dc517d6998aa1175e796d0] [e75e05d4fdb4d800e28bf41947c6b7d0168785a4] [7775bbe93d56d8ad26312c38615a9878282617e6] [e53fd166c8135afa68fefa8547423a4c4707ef81] [fd1201534e72f899d0124a2ac66bfb702197d373] [a1550eda780b4e34c48e435dce86313a5dc4bd8e] [673d8fd91dc141d25bfad8fea4d845971f35e997] [6940d16bba6d9a2baf1f8812910ca83ef79565d6] [9bc95f9eb76a816cdcfd2854717c8d1018447e92] [a4dfaea6eebf7dd50313de3133e670ea253a0f0d] [ef6ecf3e2abbd839c91724af88c1b3b8b2137521] [fa9699bc75fb06fc46bdc021d1844c670f547401] [98b26395e4ada42bb03a877955b2328de80f6443] [52b30fcdfcc8918dea1df0614aa40e8ffaf8112d] [505b184ac48f17ec696ca6bba40c09f764a0152f] [56a33501f63385afc55d84e01c27a5004565f57b] [cddadb4c006d07d566e0a8c6e73411b3d3a35b13] [7e9bdf837ade98fd535dba4ff652726fe200d3b6] [6eec2b1a1aed9ca42fa1bac9020138166b0bab31] [bfc7c7a82b03b8d207b84dd12b258c73e7f031e4] [97e1f2e2c4c21d74cf7ec4a0407276262b48d014] [f886442eb0043b3321e7745f4fa90a124fd94205] [e0dd9d12b9bf8c480eac53842e814317dc1797ba] [dca0a3011d041d727dac05cc218f62e68b1acdcf] [d59fc1358414cfac23a3d0b36735cd5db8282438] [81e567a78ec5d25375fe13dc60c02f79abbab263] [2a9c10fe0d1ab5f5c497668a461cee489f0fd7b0] [37f760bc4032b9bc089753a876db89f2b13a4160] [d1280964c96d590e7285439d6ca0494afc7c32ee] [f2b6229b343954006539167b59282a11d7f3ca6e] [0564cb19bd1d3c31d6695007cd8c95fb6bdd5768] af7685ea7b3179e919e1a7f30df5f093a25bc41c? 377d91baa4060885f8cace4541451a34885efc59? [70e128ab6f92154b551a4ddd661f2be6545a957c] [21eac75dc56150fd88663641d6775d628e9c57ab] [b0053f8d67471d341a592fb64815d1c4e732c90f] [cc548c18450e03a85898bad0e91716b48497a32b] [783bf17061ff28f5839a727a12845a53790388fd] [78d00f06573633d1fc1abbc9081b6fa9d8518fc4] [ca2c68a6f9caa64182e82a18d9c0a3c4ab85d8dc] [06d562fdbbab1c6acca5b7bb80f1bdf9c1198c80] [f999b3be594eab84f788554acd6456f873c3be2d] [8d85487dde1b2fc631c5a8f46f13ae98d4137ea8] [867f849de4323245e93a2ab3015ae1721c1da7e0] [24c0268de27b7e4f3db4f410825dfb742acaa729] [3ff33990e0e000dba57f7a8a7f37cb414228284b] [c7df9d1c75d1e45894250ab6c7e93d005684a39f] [a2087f07b407e392ce99516a7ffa9b7207627000] [b0749ee11399b60d03e64c0b24b194ae504a7fc0] [789e1acadd1d6f1aca5ba7694f97a5fc7890662f] [724979f3e482be8ec1b535ef8510b3045d1f16c1] [dd3a5d7a27d86d18bd6d02c9c86aa71d33658995] [6282f9b632351a83116f22368acb44ff7466199d] [897836379575e35b1fcd08d8732d96b083fc0fbd] [b9b1d3c6ca2e5d6f3ab00a489c024c0ede9c77a4] [7b837dd96fc3a48aea9ebb7c0b737678117efe4e] [7f1fbcaf685135d6e9e3289040fb08dc0058cc52] [68ced400e25b90dd08f7bbe7e145b59d2a3e4e63] [39f3fe7b508d83841424ed9c05cea6ab41b607e1] [6b29872f48b7eeeae855fd4682e3e3da675bc2a1] [6191657c31f3e33130d6f5e84cc044e0ec9b0268] [19dc969856040a433258dfccdad4e51385dfff5c] [b96a6c1c10ea9f35c5835124984715dfbdecf083] [db52c04f7d6db18123cb0a296987ccf5b034d0c3] [9243c46e76fa2be4877a2c2c2f34b6c1c3847a1a] [b0c4bc86596f5c78110e20d6204e9afaf35fca99]

Fixes #4616, #4605, #4627, #4638, #4624, #4618, #4641, #4652, #4631, #4667, #4670, #4642, #4650, #4618, #4692, #4658, #4630, #4705, #4629, #4712, #4684, #4720, #4672, #663, #4703, #4710, #3474, #4715, #4735, #4730, #4739, #4737, #4741, #4748, #4744, #4738, #4760, #4762, #4764, #4767, #4556, #4774, #4788, #4783, #4770, #4798, #4801, #4436, #4708, #2243, #4800, #4536, #4299, #3781, #4820, #4819, #4826, #4263, #4831, #4834, #4832, #4847, #4855, #4828

comment:19 in reply to: ↑ 18 Changed 7 years ago by Andreas Spong

Great work, keep on coding!

Note: See TracTickets for help on using tickets.