Opened 8 years ago

Closed 7 years ago

#4336 closed defect (invalid)

Strange beahvior with keys and passwords

Reported by: anonymous Owned by:
Priority: low Milestone:
Component: usability Version: hg
Severity: minor Keywords:
Cc: dominik@… Blocked By:
Blocking: OS: All

Description

I really don't know exactly if this a bug in gajim or seahorse. The fact is that after recently updating Gajim from SVN (several minutes ago, but this still exist), it asks for password only the first time I run it. Seahorse's traicon reports "Unknown key: ANSIENTTRANSIENT". If I quit gajim and run it again, no password is required and "ansienttransient" key appears.

I understand that passwords are kept using seahorse but what's about that unknown key? Why doesn't it ask me for authorisation (i cleared cached passwords/keys before running gajim)?

After I cleared passwords from seahorse's database, gajim (seahorse?) asked me for everything and seahorse's traicon contained my key. I closed gajim, cleared seahorse cache form trayicon and run gajim again. This time no questions and that "ansienttransient" key. A week (or so) ago I had to enter my password each time I run gajim.

I haven't changed seahorse preferences, so this changed behavior could be because of gajim.

Change History (10)

comment:1 Changed 8 years ago by minder

  • Cc dominik@… added

It is me who reported this. Passwords and logins don't like me recently ;)

comment:2 Changed 8 years ago by asterix

Are you talking about GPG key?

according to that debian bug I think it's a seahorse bug ...

comment:3 follow-up: Changed 8 years ago by asterix

I have seahorse 2.22.3 and everything works fine. which version do you have?

comment:4 in reply to: ↑ 3 Changed 8 years ago by minder

Replying to asterix:

I have seahorse 2.22.3 and everything works fine. which version do you have?

The same version. Gentoo Linux. The USEflags which I used: "applet avahi dbus libnotify xulrunner -debug -epiphany -gedit -gnome-keyring -ldap -nautilus"

comment:5 Changed 8 years ago by asterix

I don't see any change about GPG in the last month in our sources. I don't see what could be done wrong, we just add --use-agent to command line when Gajim is configured to use gpg agent.

comment:6 Changed 8 years ago by asterix

  • Milestone 0.12 deleted

I remove the milestone until we find an explanation to this behavior

comment:7 Changed 7 years ago by johnny

  • Status changed from new to needinfo

is this still reproducable?

comment:8 Changed 7 years ago by minder

Yes, it's still there - seahorse 2.26.2. I think I've broken my system :|

comment:9 Changed 7 years ago by johnny

let us know when you fix your system

comment:10 Changed 7 years ago by minder

  • Resolution set to invalid
  • Status changed from needinfo to closed

I updated gajim and some system components (coreutils, consolekit, gnome-keyring with its python bindings) around the time I filed last report. After that updates everything seems to be just fine. I tried to tinker with the system. I deleted the default keyring and after restart Gajim tried to create new keyring and asked for password. To me it looks like it was issue with gnome-keyring, not gajim.

Note: See TracTickets for help on using tickets.