Opened 8 years ago

Closed 7 years ago

#4012 closed defect (duplicate)

Invisible status and Gtalk/google/gmail

Reported by: bluegraydragon@… Owned by: asterix
Priority: normal Milestone: 0.12
Component: roster Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

Whatever method Google uses to become invisible, it does not work with gajim. Also, when I go invisible in gajim, status is shown as invisible, but I am not invisible.

Change History (12)

comment:1 Changed 8 years ago by asterix

Gajim uses privacy lists to become invisible, as described in XEP-0126. If gmail don't support privacy lists, there is indeed no way to become invisible, and we should make invisible line insensitive

comment:2 Changed 8 years ago by anonymous

I don't see why google can't just stick to the XEPs... Any idea how they implemented their invisible status in GMail? It looks like they simply do a <presence type="unavailable"/> but does not disconnect and then <presence /> to become visible again. But they only send that to gmail clients.

comment:3 Changed 8 years ago by asterix

  • Milestone set to 0.12
  • Resolution set to fixed
  • Status changed from new to closed

(In [15313305934edf2c6d58d5c1868c46b421caa4d9]) don't try the old (XEP-018) way to go invisible. It's not XMPP complient. That prevent to show the we are invisible but we are not. Fixes #4012

comment:4 Changed 8 years ago by js

asterix, I'm not sure if that fixes the issue discussed here.

comment:5 Changed 8 years ago by asterix

I don't understand what you mean

comment:6 Changed 8 years ago by js

If I understood it correctly, the problem is that gmail *USES* presence type='invisible' and does *NOT* support privacy lists, or did I get it wrong? If so, [15313305934edf2c6d58d5c1868c46b421caa4d9] won't fix this at all.

comment:7 Changed 8 years ago by asterix

I don't think gmail does that, it's not xmpp complient, and it's not what reporter said. I don't know what gmail do to go invisible

comment:8 Changed 8 years ago by js

Comment 2 sounded different to me, sounded like they are NOT xmpp compliant.

comment:9 Changed 8 years ago by asterix

I don't see why sending unavailable presence is not XMPP complient. It's what we do to become invisible. Read invisible XEP, it's the same.

comment:10 Changed 8 years ago by js

Sorry, wasn't reading properly. Looked at the title and somehow read invisible there instead of unavailable. My fault, never mind. Sorry for the noise.

comment:11 Changed 7 years ago by diega

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version set to svn

This still happens, I'm using hg version, and when I try to go invisible using my gmail account I get (D) gajim.c.connection Sending ERROR event to GUI: ((u'Invisibility not supported', u"Account xxxxxxxx@… doesn't support invisibility."),) but somehow gmail does support invisible status at least in their web client.

comment:12 Changed 7 years ago by diega

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.