Opened 9 years ago

Closed 9 years ago

#3464 closed defect (fixed)

Offline/online contacts very bad handling

Reported by: m_gol Owned by: asterix
Priority: high Milestone: 0.12
Component: roster Version: hg
Severity: major Keywords: metacontact contact roster position offline online
Cc: Blocked By:
Blocking: OS: All

Description

The new way of scoring metacontact position in roster doesn't make any sense to me. When a metacontact, consisting of a Jabber account and a transport account (in this case, GG transport), connects via their GG account, their roster icon doesn't go up the roster, making me unable to see it when my friend connects only via GG.

I attached 2 screenshots, one with folded metacontact and one with unfolded one.

Attachments (2)

1.png (6.5 KB) - added by m_gol 9 years ago.
unfolded metacontact
2.png (6.1 KB) - added by m_gol 9 years ago.
folded metacontact

Download all attachments as: .zip

Change History (26)

Changed 9 years ago by m_gol

unfolded metacontact

Changed 9 years ago by m_gol

folded metacontact

comment:1 Changed 9 years ago by m_gol

In svn everything's ok about that.

comment:2 Changed 9 years ago by asterix

normal, this patch is not in SVN yet ... I'll fix this behaviour before comitting it

comment:3 Changed 9 years ago by steve-e

What about this bug? Asterix, have you fixed it?

comment:4 Changed 9 years ago by m_gol

  • Version changed from 0.11.2 to 0.11.3

normal, this patch is not in SVN yet ... I'll fix this behaviour before comitting it

You know, I think it would be better just to remove this patch before it is finally fixed... It was better to handle with these little bugs than to have metacontacts ALWAYS wrong positioned... This makes stable Gajim unusable for people having metacontacts in roster.

When I install Gajim for others, I prefer to install 0.11.1 than 0.11.2 or 0.11.3. And this ticket is the main reason...

comment:5 Changed 9 years ago by asterix

  • Milestone set to 0.12
  • Resolution set to fixed
  • Status changed from new to closed

(In [da69db7213ee34890880e77e4d8d3bc69b5428ea]) in metacontacts, if one contact is offline and one is not, the online one has a higher priority. fixes #3464

comment:6 Changed 9 years ago by anonymous

  • Milestone changed from 0.12 to 0.11.4

comment:7 Changed 9 years ago by m_gol

Who changed a milestone? Will it be included in 0.11.4?

comment:8 Changed 9 years ago by asterix

I did, sorry, and yes it will be included in 0.11.4

comment:9 Changed 9 years ago by m_gol

When will it be added to svn?

comment:11 Changed 9 years ago by m_gol

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.11.3 to svn

Oh, this patch is bad. Now the situation I mentioned exists not only in 0.11.2 and 0.11.3, but also in svn. Look at the screenshots, now I have the same in my roster.

comment:12 Changed 9 years ago by m_gol

I've just realised that it doesn't work simply because... it is not commited in [3fc22709f99b74ef347649eb360a00568bf117e2]. Look at the published patch and - afterwards - at the changes in [3fc22709f99b74ef347649eb360a00568bf117e2]... They don't match to each other.

comment:14 Changed 9 years ago by asterix

  • Milestone changed from 0.11.4 to 0.12
  • Resolution set to fixed
  • Status changed from reopened to closed

(In [68ad10f80782d0df53895c494ab3812ce018e0a6]) fis metacontact behaviour. fixes #3464

comment:15 Changed 9 years ago by asterix

  • Milestone changed from 0.12 to 0.11.4

comment:16 Changed 9 years ago by m_gol

  • Resolution fixed deleted
  • Status changed from closed to reopened

Metacontacts handling haven't worked well even since this patch was applied. It still often happens to me to have online people below offline ones, especially when one logins according to this: 1) Logged into Jabber 2) Logged into Gadi-Gadu 3) Logged out of Jabber

I have latest svn, but it didn't work in previous svn versions of Gajim, too.

comment:17 Changed 9 years ago by anonymous

  • Milestone 0.11.4 deleted

comment:18 Changed 9 years ago by m_gol

That was me, sorry for I didn't log in.

comment:19 Changed 9 years ago by asterix

  • Milestone set to 0.12
  • Resolution set to fixed
  • Status changed from reopened to closed

(In [a87273861d7d12c21bf9fd6b26c12a1cd539774b]) re-compute big brother when a contact of a metacontact goes offline. fixes #3464

comment:20 follow-up: Changed 9 years ago by m_gol

  • Summary changed from Metacontacts very bad handling to Offline/online contacts very bad handling

I have latest svn and it still doesn't work. And it concerns usual contacts, too. It is visible especially when it happens for gg transport to disconnect. Then, massively, all my gg contacts get disconnected, but not each of them goes down in roster.

Something wrong was (and I hope is not now) with metacontacts handling, but here is something more about contacts handling, generally...

comment:21 Changed 9 years ago by m_gol

  • Keywords contact offline online added
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:22 Changed 9 years ago by asterix

I can't reproduce any strange behaviour. The scenario you exposed is fixed in svn now. Could you give me a scenario where things are not done correctly?

comment:23 Changed 9 years ago by asterix

ping?

comment:24 in reply to: ↑ 20 Changed 9 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to m_gol:

Then, massively, all my gg contacts get disconnected, but not each of them goes down in roster.

This is suppose to be fixed in [952802bb0c0a8df26019e16aa876e8248988946c].

Note: See TracTickets for help on using tickets.