Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#2739 closed defect (fixed)

Visual overlay bug in contact list

Reported by: infernux Owned by: asterix
Priority: normal Milestone: 0.11.2
Component: roster Version: hg
Severity: normal Keywords:
Cc: Blocked By:
Blocking: OS: All

Description

If you have the GPG icon on the right and make the list smaller it will blend together with the text. See screenshot. I tested this with more than one GTK themes.

Attachments (3)

icon.png (5.7 KB) - added by infernux 10 years ago.
Screenshot
mockup.png (5.6 KB) - added by infernux 10 years ago.
Mockup how it should look like
Screenshot.png (3.5 KB) - added by infernux 10 years ago.
compare with/without background

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by infernux

Screenshot

comment:1 follow-up: Changed 10 years ago by asterix

what's the pb ?

comment:2 in reply to: ↑ 1 Changed 10 years ago by anonymous

Replying to asterix:

what's the pb ?

Is this meant to be a "feature"? It looks like a bug. I wouldn't display the icon transparently, also, the icon seems to be displayed on a white background. And if some part of the name is cut off I would use ellipsing. Mockup follows

Changed 10 years ago by infernux

Mockup how it should look like

comment:3 follow-up: Changed 10 years ago by asterix

it is transparent because not all your accounts are securely connected.

for elipsize, I don't like cause roster is already not very large, so if we remove one or 2 more characters because we add ..., we'll see nothing

comment:4 in reply to: ↑ 3 Changed 10 years ago by anonymous

Interesting... I don't have the see-through thing anymore (donno if you noticed, on icon.png you actually see what's behind the lock icon!). Will need to try to reproduce... I see the point concerning ellipses.

But the GPG icon should not be put ontop a white background, see screenshot

Changed 10 years ago by infernux

compare with/without background

comment:5 Changed 10 years ago by infernux

Ah silly me! The see-through "bug" apperas if you select that line (merged accounts or $accountname). So to reproduce, select an account header and make the window as small as possible - and then select another line and compare

comment:6 Changed 10 years ago by asterix

I don't have your white background image bug here, image is transparent, so that should not happen.

about the see-through thing, it's a GTK+ thing. I sent them a mail to know more: gtk-list archive

comment:7 Changed 10 years ago by patrys

I vote for ellipsization. It's the right thing to do and not only with padlock icons, same applies to avatars (try and set an avatar which is a black square with transparency set to 50% to see what I mean). Looks hell of an ugly and unfortunately I can't force all my contacts to use square and opaque avatars (if the avatar is wider than taller the same visual glitch applies - you can see half of the letters below the avatar).

comment:8 Changed 10 years ago by baze

i agree, elipsizing would look better.

comment:9 Changed 10 years ago by asterix

and for contact with no avatar, we'll have an empty space on the right at the place of the avatar column, won't that look strange ?

comment:10 Changed 9 years ago by jim++

Asterix, I already have an empty space at the place of avatar. See #2473.

comment:11 Changed 9 years ago by steve-e

  • OS set to All

+1 for ellipsizations.

Those who think that this lost space looks odd can assign a custom avatar. I want to shorten messages because it looks horrible when they appear under opaque avatars.

Patch is ready, just say yes... :-)

comment:12 Changed 9 years ago by asterix

commit it, we'll what users think about that :)

comment:13 Changed 9 years ago by steve-e

  • Milestone set to 0.12
  • Resolution set to fixed
  • Status changed from new to closed

(In [a3917a505e5dd258841c10d644a9b9f8a32ce7f7]) Enable ellipsization in roster and chatwindow. Fixes #2079, #2739 Reorder occupantlist in groupchat to match roster. Fixes #2102

comment:14 Changed 9 years ago by asterix

(In [0479132b4b1e9497f6d4856088c237d5b8a4726d]) Enable ellipsization in roster and chatwindow. Fixes #2079, #2739 Reorder occupantlist in groupchat to match roster. see #2102

comment:15 Changed 9 years ago by asterix

  • Milestone changed from 0.12 to 0.11.2
Note: See TracTickets for help on using tickets.