Opened 10 years ago

Closed 7 years ago

#2256 closed enhancement (fixed)

[From gajim-dev ML]: Is it possible to disable sounds when i am away ?

Reported by: dkirov Owned by: js
Priority: normal Milestone: 0.13
Component: None Version:
Severity: normal Keywords:
Cc: s.kalyanasundaram@… Blocked By:
Blocking: OS: All

Description

As a beginning we can add ACE option for that: disable_sounds_when_not_online This option will be usefull for ppl who fall asleep on the comp.

Attachments (1)

Screenshot-gajim-Preferences.png (40.5 KB) - added by kalyan 8 years ago.
new option in the preference window to do this request

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by dkirov

  • Type changed from defect to enhancement

comment:2 Changed 10 years ago by jim++

This could be done using #1005, but not in an user friendly way.

comment:3 Changed 8 years ago by dsas

  • OS set to All

3150 looks like a duplicate of this bug

comment:4 Changed 8 years ago by js

  • Milestone set to 0.13
  • Owner changed from asterix to js

I definitely want that for 0.13, because I think it's annoying to get sounds when I'm DND and watching a film for example.

Guess I'll implement that after 0.12.

comment:5 Changed 8 years ago by kalyan

  • Cc s.kalyanasundaram@… added

Changed 8 years ago by kalyan

new option in the preference window to do this request

comment:6 Changed 8 years ago by kalyan

Sometime, ppl do change the status to invisible or away and working. During that time it will be good not to avoid the sound events. So better will introduce a option the preference window. "Play sound only when online". Please refer the above screen shot..

comment:7 Changed 8 years ago by Jim++

See #1106.

I think it makes more senses that it is changed only for "busy" status.

comment:8 Changed 7 years ago by asterix

to be consistent with "Allow popup/notifications when I'm away/na/busy/invisible" I would call it "Allow sounds when I'm away/na/busy/invisible" or merge both options: "Allow popup/notifications/sound when I'm away/na/busy/invisible"

comment:9 Changed 7 years ago by js

It would be nice to have it for away/na/invisible and dnd. The first mean that you're likely not there, while the last means that you definitely don't want to be disturbed. So I would like to have notifications when I'm invisible/away/na, but not when I'm DND :).

comment:10 Changed 7 years ago by asterix

Isn't it too much options if we do both? We do only for DND?

comment:11 Changed 7 years ago by js

Only for DND sounds fine, as if you're away, you won't notice anyway :). The questions is: Invisible and DND together or only DND?

comment:12 Changed 7 years ago by asterix

  • Resolution set to fixed
  • Status changed from new to closed

(In [fa44c8adedf45d3c9b2d074e964c05f9f7938efc]) option to disable sound when we are busy. Fixes #2256

Note: See TracTickets for help on using tickets.