Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#1535 closed defect (invalid)

Gajim seg faults on Gentoo / Gnome 2.12

Reported by: anonymous Owned by: asterix
Priority: high Milestone:
Component: None Version: 0.9.1
Severity: normal Keywords: segmentation fault
Cc: martel@… Blocked By:
Blocking: OS:

Description

While trying to load, gajim crashes with Segmentation fault. I have an up to date system. The last messages after issuing the -v to python are:

import gnome # precompiled from /usr/lib/python2.4/site-packages/gtk-2.0/gnome/__init__.pyo
dlopen("/usr/lib/python2.4/site-packages/gtk-2.0/gnome/_gnome.so", 2);
import gnome._gnome # dynamically loaded from /usr/lib/python2.4/site-packages/gtk-2.0/gnome/_gnome.so
dlopen("/usr/lib/python2.4/site-packages/gtk-2.0/gnome/ui.so", 2);
dlopen("/usr/lib/python2.4/site-packages/gtk-2.0/gnomevfs.so", 2);
dlopen("/usr/lib/python2.4/site-packages/ORBit.so", 2);
# /usr/lib/python2.4/keyword.pyo matches /usr/lib/python2.4/keyword.py
import keyword # precompiled from /usr/lib/python2.4/keyword.pyo
import ORBit # dynamically loaded from /usr/lib/python2.4/site-packages/ORBit.so
import gnomevfs # dynamically loaded from /usr/lib/python2.4/site-packages/gtk-2.0/gnomevfs.so
# /usr/lib/python2.4/site-packages/bonobo.pyo has bad mtime
/usr/lib/python2.4/site-packages/bonobo.py: inconsistent use of tabs and spaces in indentation
import bonobo # from /usr/lib/python2.4/site-packages/bonobo.py
# can't create /usr/lib/python2.4/site-packages/bonobo.pyo
dlopen("/usr/lib/python2.4/site-packages/oafmodule.so", 2);
Segmentation fault

Change History (15)

comment:1 Changed 10 years ago by martel@…

I'm sorry, I have posted as anonymous. I think I should leave some mail.

comment:2 Changed 10 years ago by nk

  • Cc martel@… added

how did you get that output??

was gajim ever working for you?

please mention your version of gcc python pygtk gtk and the output after reading ReportingSegfault so I can help

comment:3 Changed 10 years ago by martel@…

Gajim on Gentoo gets executed by: exec python -OOt gajim.py $@

I have just added verbose switch: exec python -OOtv gajim.py $@

Yes, gajim was working form me before. I don't know the exact moment where it ceased to run, though.

Versions (python is at 2.4 version as you can read in above verbose output):

Python 2.4.2
gcc version 3.3.5-20050130 (Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1)
pygtk-2.8.2
gtk+-2.8.8 (upgrading to 2.8.11 at the moment)

I'll try to run gdb in a moment.

comment:4 Changed 10 years ago by anonymous

And the gdb output:

(gdb) run gajim.py
Starting program: /usr/bin/python gajim.py
(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -1211947328 (LWP 13637)]
[New Thread -1227383888 (LWP 13638)]
[New Thread -1235776592 (LWP 13639)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1211947328 (LWP 13637)]
0xb6e13487 in initoaf () from /usr/lib/python2.4/site-packages/oafmodule.so

comment:5 Changed 10 years ago by nk

  • Resolution set to invalid
  • Status changed from new to closed

Q16. I'm running gentoo x86_64 and gajim segfaults, how to fix it?

  1. In few words - upgrade your gcc to 4.0.x and reemerge python, gtk+ and pygtk. (http://bugs.gentoo.org/show_bug.cgi?id=109298)

from GajimFaq

comment:6 Changed 10 years ago by martel@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

But I'm not running it on x86_64 - it's still 32. I'll reopen the bug if it's ok with you. I would also like to point out that it was working without problems some time ago. I'll keep you informed.

comment:7 Changed 10 years ago by nk

yes you're right on that. the pb is that after x86_64 I don't trust Gentoo to deliver new pygtk/gtk with gcc 3.3 that is just old. I really hope your pbs is elsewhere and is easier to fix, but perhaps you would like to report against Gentoo?

I leave open, but I cannot repro

comment:8 Changed 10 years ago by nicfit

FWIW, I'm using gentoo, gnome 2.12, and gajim with much success.

comment:9 Changed 10 years ago by dkirov

Me too, but I don't have the problematic oafmodule.so

As far as I can see it is part of the dead, unmaintained and unused bonobo-python. Can you try:

$ equery belongs oafmodule.so
$ equery depends bonobo-python 

just to be sure. Thanks

comment:10 Changed 10 years ago by nk

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:11 Changed 10 years ago by martel@…

I have unmerged bonobo-python, re-emerged libbonobo, libbonoboui, pygtk and gnome-python, and now gajim cannot find bonobo.ui:

ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "gajim.py", line 1504, in ?
    cli.set_restart_command(argv)
AttributeError: '__main__.GnomeClient' object has no attribute 'set_restart_command'

I guess I will have to go to gentoo forums now. Thanks for help, anyway.

comment:12 Changed 10 years ago by dkirov

file /usr/portage/dev-python/bonobo-python/bonobo-python-0.2.0-r5.ebuild :

DEPEND="=x11-libs/gtk+-1.2*
    >=gnome-base/bonobo-1.0.9
    <dev-python/gnome-python-1.99
    =dev-python/orbit-python-0.3*
    =dev-python/pygtk-0.6*
    virtual/python"

from what I see above it is impossible to have bonobo-python with gnome-2.12 at the same time. The required version of gnome-python is 2* not 1* Have you ever done emerge --update --deep ?

Maybe you didn't unmasked all the required packages, try with emerge -DuNav world and it will tell you what you've missed.

comment:13 Changed 10 years ago by martel@…

It is possible to have bonobo-python and gnome because I do have them both installed ;). You missed the fact gnome-python is slotted (gnome-python-1.4.4-r1 is SLOT 1, gnome-python-2.12.1 is SLOT 2). And I have both of them installed.

The deep emerge of gajim wants to update only one package related to python [ebuild U ] dev-python/pycairo-1.0.2 [0.9.0]. I think the rest is not important in this case (I can put the whole list here if you like, of course). And I would like to avoid recompiling gcc (from 3.3.5 to 3.3.6), glibc (2.3.4.20041102-r1 to 2.3.5-r2) and for example xorg (6.8.2-r2 to 6.8.2-r6).

I think I'm beggining to remember when gajim stopped working. As far as I remember I tried to compile the gnochm some time ago and tried to install all the requirements. I have to look into it.

Thanks for your help and time. I really appreciate it.

comment:14 Changed 10 years ago by martel@…

Problem resolved - I have gajim running at the moment.

I think it was the unmerging of gnome-python-1.4.4-r1, unmerging bonobo-python and reemerging gnome-python-2.12.1 what resolved the issue. Yet I'm not really sure about it since gajim began working after the hard reboot (sic!). When I have checked it the moment after the whole emerging process completed gajim was still trying to import bonobo.ui on load. Seems like system was feeding gajim the wrong version of the library all the time.

Thanks again for your time. And sorry for stiring up the water ;)

comment:15 Changed 10 years ago by dkirov

  • Severity changed from critical to normal

Thank you too, I sent a gentoo bug:

http://bugs.gentoo.org/show_bug.cgi?id=122762

Note: See TracTickets for help on using tickets.