Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1328 closed defect (fixed)

contact which we don't know his status, but he knows ours, cannot be removed from our roster

Reported by: nk Owned by: asterix
Priority: normal Milestone: 0.10
Component: roster Version: hg
Severity: normal Keywords:
Cc: lucas@… Blocked By:
Blocking: OS:

Description

I don't know if it's a feature of Lucas' JEP but anyways it's super annoying ;)

Change History (19)

comment:1 Changed 10 years ago by nk

  • Cc lucas@… added

Lucas, what do you think?

comment:2 Changed 10 years ago by lucas@…

What do you mean exactly by "cannot be removed from our roster" ?

comment:3 Changed 10 years ago by nk

Lucas, I mean next time we login, we show it in roster.

is this our bug or a bug of JEP conditions?

comment:4 Changed 10 years ago by lucas@…

It's the bug in the way you implemented JEP 0162 : since the contact should have subscribe=from and no name or group child, you should not display it. Check that you test the cases of section 3 correctly. http://www.jabber.org/jeps/jep-0162.html#contacts

comment:5 Changed 10 years ago by nk

thanks lucas

Yann, you have your answer :)

comment:6 Changed 10 years ago by asterix

it's the pb, if we don't display the contact, we can't remove it.

comment:7 Changed 10 years ago by nk

yea but we cannot remove the contact!

contact which we don't know his status, but he knows ours is always shown in our roster no matter what *we* do

comment:8 Changed 10 years ago by anonymous

asterix: contacts with presence = from can be displayed in an Observers group (see the JEP). Implementing this would solve your problem.

nk: exactly.

comment:9 Changed 10 years ago by asterix

so there is no bug in the way we implement that. Your contact has probably a group or a name configured, and it's ok to show it according to the JEP. (I don't think it's a good thing forthe name as all contacts have one, but it's the JEP).

lucas, do you think JEP could be updated so that items with subscription='none' or subscription='from' which have no 'group' child set are hidden even if they have a name attribute ? Most client always add a name to the contact.

I'm adding the observer group and the Hidden group, but we'll see them only when show offline contacts is on

comment:10 Changed 10 years ago by asterix

  • Status changed from new to assigned

comment:11 Changed 10 years ago by lucas@…

What if you remove the <name/> when people "remove" the contact ?

comment:12 Changed 10 years ago by lucas@…

Some people with short contact lists might want not to use groups at all.

comment:13 Changed 10 years ago by asterix

and what will we see in the roster in the hidden group ? the jid ? user may not recognize the contact.

comment:14 Changed 10 years ago by lucas@…

i don't understand the problem :

  • The observer group shows JIDs which are watching you, but you don't want to normally have in your roster. Only the JID is displayed.
  • The Hidden group might not be necessary. It's about being able to name contacts, but not display them (when you want to clean up your observers list).

Please implement the observers group, and then we can discuss the hidden group if you still feel it's necessary to implement it.

comment:15 Changed 10 years ago by asterix

I've just implemented it, and the problem is this one:

I have a contact in my roster (jid qwe@…, group test, name=friend)

he remove my auth so now I have sub=from, so it should go to observer group, but he doesn't cause it has a group and a name value. I have to remove the group (but if I ask him auth and he authorize me the group in which he was before is lost). And I have to remove the name (but in such a case I'll see 'qwe@…' in my roster instead of 'friend' and I may not recognize it's him).

comment:16 Changed 10 years ago by anonymous

Please re-read the JEP about the Hidden group. The Hidden group is never displayed, because it is a way to mark clients that you don't want to see.

comment:17 Changed 10 years ago by anonymous

regarding Observers group, if you still have a name/group set, it means that you are interested in keeping it in your roster all the time (as a shortcut, for example). But if you "remove" it, gajim should remove the name and the group, and then I'll go to the observers group.

The goal of the observers group is to answer the question "some people are watching me. I'm usually not interested in them, but right now, I'd like to know who they are."

comment:18 Changed 10 years ago by nk

Lucas, okay so can you propose a way a client can implement this (hidden and observers group)? UI options? default to what etc.. thx

comment:19 Changed 10 years ago by asterix

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed by [60b8256af545b5d71a9b6b3014346f4920fc35b1]. Observer group is here

Note: See TracTickets for help on using tickets.